Recording URL link problem in user_stats.php

Any and all non-support discussions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Recording URL link problem in user_stats.php

Postby h.khan » Tue Mar 12, 2019 4:38 pm

hi all i have a problem cant find proper solution on it ,, in user_stats.php at RECORDINGS FOR THIS TIME PERIOD: (10000 record limit) when i click on url like http://xxxxxxx/RECORDINGS/DTV_20190312- ... 47-all.wav the page with error 404 not found but when i change the capital letter "RECORDINGS" to lower case "recordings" the url will work and show the audio file , plz help to change the link in user_stats.php to RECORDINGS -> recordings
h.khan
 
Posts: 2
Joined: Wed Dec 19, 2018 7:38 pm

Re: Recording URL link problem in user_stats.php

Postby williamconley » Tue Mar 12, 2019 5:29 pm

1) Welcome to the Party! 8-)

2) As you are obviously new here, I have some suggestions to help us all help you:

When you post, please post your entire configuration including (but not limited to) your installation method (7.X.X?) and vicidial version with build (VERSION: 2.X-XXXx ... BUILD: #####-####).

This IS a requirement for posting along with reading the stickies (at the top of each forum) and the manager's manual (available on EFLO.net, both free and paid versions)

You should also post: Asterisk version, telephony hardware (model number is helpful here), cluster information if you have one, and whether any other software is installed in the box. If your installation method is "manual/from scratch" you must post your operating system with version (and the .iso version from which you installed your original operating system) plus a link to the installation instructions you used. If your installation is "Hosted" list the site name of the host.

If this is a "Cloud" or "Virtual" server, please note the technology involved along with the version of that techology (ie: VMware Server Version 2.0.2). If it is not, merely stating the Motherboard model # and CPU would be helpful.

Similar to This:

Vicibox X.X from .iso | Vicidial X.X.X-XXX Build XXXXXX-XXXX | Asterisk X.X.X | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation | Intel DG35EC | Core2Quad Q6600

3) This is not a "General Discussion", it's a support request. I will move it to the Support board where it belongs. Please read the sticky posts at the top of any forum before posting. This rule applies to every online support forum, not just Vicidial. It's a simple matter of online etiquette to have these and to read them before posting. They help you to understand what the forum is for and how it operates.

4) are you pushing the recordings to an archive/ftp server?

if so: Post the content of the recordings section (blot out the user/password) from /etc/astguiclient.conf.

if not: post the values in admin -> servers related to recordings (Recording Web Link: and the two below it) on the server in question

5) Apache settings:

Code: Select all
grep recordings /etc/apache2/* -Rin
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 18177
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Recording URL link problem in user_stats.php

Postby h.khan » Wed Mar 13, 2019 1:18 pm

hi williamconley thanks for reply and thanks for posting tips and rules i figure it out the error which im facing the link i mention "http://xxxxxxx/RECORDINGS/DTV_20190312-142230_7242_2259004547-all.wav", is not working and say 404 not found , same link i just replace the word "RECORDINGS" to small letters "recordings" the link works , so i edit the file user_stats.php on line 1390 with little trick regex {$location = preg_replace('/\bRECORDINGS\b/', 'recordings', $location); $location = "<a href=\"$location\">$locat</a>";} it will find the match word "RECORDINGS" in string $location and replace the word to small letters "recordings" now link is working properly ,
h.khan
 
Posts: 2
Joined: Wed Dec 19, 2018 7:38 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 9 guests