Inbound not working for Amazon

Any and all non-support discussions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Inbound not working for Amazon

Postby arunabh » Fri Nov 01, 2019 5:27 am

Hi,

This is Arunabh from India. We are running two outbound processes and I am looking after the vicidial server. The outbound is running fine and good, but the issue is with the inbound DID call landing because we are going to run one for sale Amazom process where customers will call into our purchased DID number.

I have configured the Inbound DID,In-group and campaign following thoroughly the managers manual, but the confusion is with carrier configuration.

Following is the inbound carrier details:

[testcarrier23492]
disallow=all
allow=ulaw
allow=g729
type=friend
username=DialitesInbound
fromuser=DialitesInbound
secret=Di&thy8dh2487
host=103.94.86.53
context=trunkinbound
insecure=port,invite
dtmfmode=rfc2833
usecallerid=yes
trustrpid=no
sendrpid=yes
requirecalltoken=no
nat=yes

Global String:

TESTSIPTRUNK23492=SIP/testcarrier23492

Dialplan Entry:

exten => _492.,1,AGI(agi://127.0.0.1:4577/call_log)
exten => _492.,2,Dial(${TESTSIPTRUNK23492}/${EXTEN:3},,tTor)
exten => _492.,3,Hangup

I am using vicibox 7
Version : 2.14-718a

As I am new to setup inbound campaign please suggest.

I have tried the following dial plan but it is not working:

exten => DID-number,1,Ringing
exten => DID-number,2,Wait(1)
exten => DID-number,3,Answer
exten => DID-number,4,AGI(agi://127.0.0.1:4577/call_log)
exten => DID-number,5,AGI(agi-DID_route.agi)
exten => DID-number,6,Hangup

The issue is that when agents logged in campaign and I called the DID it is not landing.
DID: All USA
DID No: 12xxxxx6003

I have called the DID from different connection and Skype also but the result is the same.

Please suggest as I need to complete it ASAP.

And please suggest me where I should put the dialprefix ? Is that same as outbound ?
arunabh
 
Posts: 1
Joined: Thu Oct 03, 2019 12:39 am

Re: Inbound not working for Amazon

Postby ambiorixg12 » Fri Nov 08, 2019 10:35 am

First thing you need to do it is enable the asterisk sip de bug and verify if the INVITE request from the DID provider is reaching your server sip set debug on
Asterisk and FreePBX expert / Twilio & PHP / Python MYSQL developer.

Personal site : http://asterisk-voip.com/
ambiorixg12
 
Posts: 300
Joined: Tue Sep 17, 2013 10:35 pm


Return to General Discussion

Who is online

Users browsing this forum: Bing [Bot] and 10 guests