NAT Settings External Phone

Any and all non-support discussions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

NAT Settings External Phone

Postby rbbumanlag » Fri Apr 28, 2017 12:43 am

Hi,

ViciBox 6.0.4.(iso) | Asterisk 1.8.32-3-vici | VERSION: 2.14-594a BUILD: 170226-0850 | Cluster Setup | Intel(R) Xeon(R) CPU E5-2609 V3 | 16GB DDR4 RAM | 1TB (SAS) |No Digium/Sangoma Hardware | No Extra Software After Installation | Virtualized on XenServer

Question:

Why is there no audio after the call is answered on 2 phones? 1st phone is in the office. 2nd phone is registered through public ip.

On my Firewall side:
created the following NAT UDP
Public ip port 5060 to private ip port 5060
Public ip port 10000-20000 to private ip port 10000-20000
Public ip port 4569 to private ip port 4569

Then on sip.conf (through cli)
externip = mypublicip (also set external ip through web gui on server settings)
localnet = myprivatenetworks
nat = yes

On the Phone
External IP = yes (thru web gui vicidial)

I was able to register my extensions sip account but no audio when calling for both in and out.

one questions is that what is the 192.168.43.121? I do not have this private ip address.

Please see below logs.
[Apr 28 13:31:37] Scheduling destruction of SIP dialog 'NmJlNzU2OGNhYjUxOGYzYmMwZDYzNTYzZDM2NDYwZjI.' in 6784 ms (Method: SUBSCRIBE)
[Apr 28 13:31:37]
<--- SIP read from UDP:PublicIPClient:42956 --->
ACK sip:12348051121@PublicIPSIPServer:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.43.121:36957;branch=z9hG4bK-d8754z-61869ad0b77f0b1a-1---d8754z-
Max-Forwards: 70
Contact: <sip:100@192.168.43.121:36957;transport=UDP>
To: <sip:12348051121@PrivateIPSIPServer;transport=UDP>;tag=as11702284
From: <sip:100@PrivateIPSIPServer;transport=UDP>;tag=97227b3d
Call-ID: ZmUwODQ4NTE4ODE4NWI0ZWMyYjFmMzM1ZTdhNDc1Yzc.
CSeq: 2 ACK
User-Agent: Z 3.6.25251 r25476
Authorization: Digest username="100",realm="asterisk",nonce="7a2ea13e",uri="sip:12348051121@PublicIPSIPServer;transport=UDP",response="2b6229ae4bcca4249503d29b9bca0332",algorithm=MD5
Content-Length: 0

<--- SIP read from UDP:PublicIPClient:42956 --->
SUBSCRIBE sip:100@PrivateIP:5060;transport=UDP SIP/2.0
Via: SIP/2.0/UDP 192.168.43.121:36957;branch=z9hG4bK-d8754z-8a5f578ce5cc3a6f-1---d8754z-
Max-Forwards: 70
Contact: <sip:100@192.168.43.121:36957;transport=UDP>
To: <sip:100@PrivateIPSIPServer;transport=UDP>
From: <sip:100@PrivateIPSIPServer;transport=UDP>;tag=bb67b140
Call-ID: NmJlNzU2OGNhYjUxOGYzYmMwZDYzNTYzZDM2NDYwZjI.
CSeq: 2 SUBSCRIBE
Expires: 600
Accept: application/watcherinfo+xml
llow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, MESSAGE, OPTIONS, INFO, SUBSCRIBE
Supported: replaces, norefersub, extended-refer, timer, X-cisco-serviceuri
User-Agent: Z 3.6.25251 r25476
Authorization: Digest username="100",realm="asterisk",nonce="7dd4b356",uri="sip:100@PublicIPSIPServer;transport=UDP",response="42755315f300eb4efd162ffba9a39249",algorithm=MD5
Event: presence.winfo
Allow-Events: presence, kpml
Content-Length: 0

Apr 28 13:31:37] --- (17 headers 0 lines) ---
[Apr 28 13:31:37] Creating new subscription
[Apr 28 13:31:37] Sending to PublicIPClient:42956 (NAT)
[Apr 28 13:31:37] Found peer '100' for '100' from PublicIPClient:42956
[Apr 28 13:31:37] Looking for 100 in default (domain PrivateIPSIPServer)
[Apr 28 13:31:37]

<--- Transmitting (NAT) to PublicIPClient:42956 --->
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 192.168.43.121:36957;branch=z9hG4bK-d8754z-8a5f578ce5cc3a6f-1---d8754z-;received=121.54.44.170;rport=42956
From: <sip:100@PrivateIPSIPServer;transport=UDP>;tag=bb67b140
To: <sip:100@PrivateIPSIPServer;transport=UDP>;tag=as204e048b
Call-ID: NmJlNzU2OGNhYjUxOGYzYmMwZDYzNTYzZDM2NDYwZjI.
CSeq: 2 SUBSCRIBE
Server: Asterisk PBX 1.8.32.3-vici
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Content-Length: 0
rbbumanlag
 
Posts: 33
Joined: Mon Sep 26, 2016 10:37 am

Re: NAT Settings External Phone

Postby rbbumanlag » Sat May 06, 2017 11:29 am

Hi,

Still I was not able to make SIP work.

What I did is use iax2. By using Iax2 and using exsiting settings, I was able to make a call and did not encounter any problem.

The only difference in my firewall settings is that I used 4569 for IAX2. but still using SIP with port 5060, I was able to register but no audio.

Sip.conf
Nat = yes
externip = public ip
localnet = local network

Phone:
External IP = Yes
rbbumanlag
 
Posts: 33
Joined: Mon Sep 26, 2016 10:37 am

Re: NAT Settings External Phone

Postby rrb555 » Wed May 10, 2017 7:12 pm

I believe it has something to do with the firewall.
One server that I am managing | Single Server | ViciBox Redux 6.0 | VERSION: 2.12-549a | BUILD: 160404-0940 | revision 2508| No other hardware
For help you can send me a direct email info@support.com.ph
rrb555
 
Posts: 555
Joined: Tue Feb 08, 2011 4:24 pm
Location: Quezon City, Philippines


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 8 guests