Upgrade CPAN module Net::Telnet if installed before May 2013

Any and all non-support discussions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Upgrade CPAN module Net::Telnet if installed before May 2013

Postby mflorell » Thu Sep 21, 2017 5:46 pm

We are going to start requiring the 3.0.4 version of the Net::Telnet CPAN Perl module with svn/trunk code as of revision 2817.

This version of the Net::Telnet perl module isn't new, it was released on April 21, 2013. So most systems installed after that date should not need to upgrade the perl module.

We are requiring this upgrade to support a larger telnet data buffer, which has shown to help stability and reliability of higher-volume dialing systems.

This is only a requirement for dialer servers, not dedicated web or database servers.


The install of this updated module is pretty simple and usually only requires two commands to be issued on the Linux Command line:

# cpan
> install Net::Telnet
> quit


I just went through the process of manually updating almost 100 older servers on our hosted cluster and it only took me about 45 minutes.

If you have any questions, please post them here.
mflorell
Site Admin
 
Posts: 16336
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Upgrade CPAN module Net::Telnet if installed before May

Postby williamconley » Fri Sep 22, 2017 1:27 pm

Test your Net::Telnet Version:
Code: Select all
cpan -D Net::Telnet


Possible result (after about 50 lines of ... stuff) for a Vicibox Redux 3.1.14:

Code: Select all
Net::Telnet
-------------------------------------------------------------------------
        Interact with TELNET port or other TCP ports
        J/JR/JROGERS/Net-Telnet-3.04.tar.gz
        /usr/lib/perl5/vendor_perl/5.12.1/Net/Telnet.pm
        Installed: 3.03
        CPAN:      3.04  Not up to date
        Jay Rogers (JROGERS)
        jay@rgrs.com


Shows 3.03 installed, 3.04 available.

Upgrade since it's out of date:
Code: Select all
cpan -I Net::Telnet


Check again to see success if you're anal:
Code: Select all
cpan -D Net::Telnet

The only output this time is the final portion with up to date.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 16688
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Upgrade CPAN module Net::Telnet if installed before May

Postby mflorell » Fri Sep 22, 2017 3:33 pm

Thanks for posting William :)
mflorell
Site Admin
 
Posts: 16336
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Upgrade CPAN module Net::Telnet if installed before May

Postby williamconley » Fri Sep 22, 2017 4:11 pm

mflorell wrote:Thanks for posting William :)

You do the hard part, I post tidbits after dumbing it down for myself. lol
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 16688
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 10 guests