dahdi compiling error - vicibox 8

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

dahdi compiling error - vicibox 8

Postby ZeeTech » Wed Jul 11, 2018 11:40 am

Hi, i have setup a fresh ViciBox 8.0.1 on Dell R730 with openvox single port PRI card, now in order to configure the openvox PRI card i am trying to install openvox customized dahdi verision but i am facing following error, please help.

After fresh vicibox express install i do following
Code: Select all
zypper up
zypper --non-interactive in -t pattern devel_kernel
zypper --non-interactive in kernel-syms patchutils dahdi-linux-devel libpri-devel asterisk-devel gcc-c++
killall -9 asterisk
/etc/init.d/dahdi stop
cd dahdi

make -C linux clean
make[1]: Entering directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux'
make -C drivers/dahdi/firmware clean
make[2]: Entering directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/firmware'
rm -f dahdi-fw-*.o
make[2]: Leaving directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/firmware'
make -C  M='/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/oct612x' clean
make[2]: Entering directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux'
make[2]: *** M=/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/oct612x: No such file or directory.  Stop.
make[2]: Leaving directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux'
Makefile:179: recipe for target 'clean' failed
make[1]: *** [clean] Error 2
make[1]: Leaving directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux'
Makefile:14: recipe for target 'clean' failed
make: *** [clean] Error 2
vicibox8:/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1 # make all
make -C linux all
make[1]: Entering directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux'
make -C drivers/dahdi/firmware firmware-loaders
make[2]: Entering directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/firmware'
Attempting to download dahdi-fwload-vpmadt032-1.25.0.tar.gz
--2018-07-11 21:31:40--  http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fwload-vpmadt032-1.25.0.tar.gz
Resolving downloads.digium.com (downloads.digium.com)..., 2001:470:e0d4::ee
Connecting to downloads.digium.com (downloads.digium.com)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 149360 (146K) [application/x-gzip]
Saving to: ‘dahdi-fwload-vpmadt032-1.25.0.tar.gz’

100%[==================================================================================>] 149,360     --.-K/s   in 0.003s

2018-07-11 21:31:42 (48.4 MB/s) - ‘dahdi-fwload-vpmadt032-1.25.0.tar.gz’ saved [149360/149360]

make[2]: Leaving directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/firmware'
You do not appear to have the sources for the 4.4.138-59-default kernel installed.
Makefile:71: recipe for target 'modules' failed
make[1]: *** [modules] Error 1
make[1]: Leaving directory '/usr/local/src/dahdi-linux-complete-2.11.1+2.11.1/linux'
Makefile:9: recipe for target 'all' failed
make: *** [all] Error 2

I tried same on another test VM and facing same error while compiling dahdi, please help me to rectify this issue.
Posts: 68
Joined: Sun Apr 04, 2010 5:45 am

Re: dahdi compiling error - vicibox 8

Postby omarrodriguezt » Tue Feb 19, 2019 10:39 am

Can you try the same in a real machine, not virtual?
Dedicated USA Servers - Vicibox - Vicidial - Limesurvey - Vtiger CRM - More than 15 years experience - Hablamos Español
Posts: 666
Joined: Fri Jun 05, 2009 12:22 pm
Location: Dominican Republic

Re: dahdi compiling error - vicibox 8

Postby williamconley » Tue Feb 19, 2019 12:43 pm

This is an issue you'll need to take up with those who customized dahdi as you stated in your post. The vicidial group did not create this dahdi app.

That's like going back to the auto dealer for service on an after-market turbo you had put on the engine. The dealer is likely very capable of resolving the issue, but it sure as heck isn't going to be free or covered under warranty. The guys that sold you the turbo, however, should certainly be able to service it.

So start with the guys that customized the dahdi code.

I do see a folder-not-found error which seems to be the first problem encountered. This may be due to OpenSuSE having a different directory structure than other linux distros. But that's a wild guess.

Also: This is not a "general discussion", but a support request. Moving to the appropriate board.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
Posts: 18318
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Return to Support

Who is online

Users browsing this forum: No registered users and 13 guests