calls not coming IN in agent..for predictive dialing

Any and all non-support discussions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

calls not coming IN in agent..for predictive dialing

Postby marveelou » Tue Mar 01, 2022 12:35 am

I'm using vicibox 8.0 ISO, outbound is working but when I enable auto-dialing no calls come to the agents. Kindly assist

-- Executing [138368@default:3] Hangup("Local/63318189220957@default-0000004c;1", "") in new stack
[Mar 1 13:33:07] == Spawn extension (default, 138368, 3) exited non-zero on 'Local/63318189220957@default-0000004c;1'
[Mar 1 13:33:07] WARNING[12644][C-00000086]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
[Mar 1 13:33:07] -- Executing [h@default:1] AGI("Local/63318189220957@default-0000004c;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar 1 13:33:07] -- <Local/63318189220957@default-0000004c;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ----------) completed, returning 0
[Mar 1 13:33:07] -- Channel Local/63318189220957@default-0000004c;2 left 'simple_bridge' basic-bridge <521642d1-fe0d-43f0-9c40-ae8ba9f0cfae>
[Mar 1 13:33:07] -- Channel SIP/airespring-0000004d left 'simple_bridge' basic-bridge <521642d1-fe0d-43f0-9c40-ae8ba9f0cfae>
[Mar 1 13:33:07] == Spawn extension (default, 63318189220957, 3) exited non-zero on 'Local/63318189220957@default-0000004c;2'
[Mar 1 13:33:07] -- Executing [h@default:1] AGI("Local/63318189220957@default-0000004c;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----3-----2-----SIP 200 OK)") in new stack
[Mar 1 13:33:07] -- <Local/63318189220957@default-0000004c;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... -2-----SIP 200 OK) completed, returning 0
[Mar 1 13:33:07] -- Executing [138368@default:3] Hangup("Local/63318189220957@default-0000004d;1", "") in new stack
[Mar 1 13:33:07] == Spawn extension (default, 138368, 3) exited non-zero on 'Local/63318189220957@default-0000004d;1'
[Mar 1 13:33:07] WARNING[12651][C-00000087]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
[Mar 1 13:33:07] -- Executing [h@default:1] AGI("Local/63318189220957@default-0000004d;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar 1 13:33:07] -- <Local/63318189220957@default-0000004d;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ----------) completed, returning 0
[Mar 1 13:33:07] -- Channel Local/63318189220957@default-0000004d;2 left 'simple_bridge' basic-bridge <acc681e6-377a-4d42-bdfe-f3d6a3184220>
[Mar 1 13:33:07] -- Channel SIP/airespring-0000004e left 'simple_bridge' basic-bridge <acc681e6-377a-4d42-bdfe-f3d6a3184220>
[Mar 1 13:33:07] == Spawn extension (default, 63318189220957, 3) exited non-zero on 'Local/63318189220957@default-0000004d;2'
[Mar 1 13:33:07] -- Executing [h@default:1] AGI("Local/63318189220957@default-0000004d;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----3-----2-----SIP 200 OK)") in new stack
[Mar 1 13:33:07] -- <Local/63318189220957@default-0000004d;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... -2-----SIP 200 OK) completed, returning 0
[Mar 1 13:33:07] -- Executing [138368@default:3] Hangup("Local/63318189220957@default-0000004e;1", "") in new stack
[Mar 1 13:33:07] == Spawn extension (default, 138368, 3) exited non-zero on 'Local/63318189220957@default-0000004e;1'
[Mar 1 13:33:07] WARNING[12656][C-00000088]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
[Mar 1 13:33:07] -- Executing [h@default:1] AGI("Local/63318189220957@default-0000004e;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar 1 13:33:07] -- <Local/63318189220957@default-0000004e;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ----------) completed, returning 0
[Mar 1 13:33:07] -- Channel Local/63318189220957@default-0000004e;2 left 'simple_bridge' basic-bridge <781f753c-008c-4da9-b847-1b29e960175c>
[Mar 1 13:33:07] -- Channel SIP/airespring-0000004f left 'simple_bridge' basic-bridge <781f753c-008c-4da9-b847-1b29e960175c>
[Mar 1 13:33:07] == Spawn extension (default, 63318189220957, 3) exited non-zero on 'Local/63318189220957@default-0000004e;2'
[Mar 1 13:33:07] -- Executing [h@default:1] AGI("Local/63318189220957@default-0000004e;2", "agi://127.0.0.1:4577/call_log--HVcauses-
Marvee Lou Ventures
System Admin/Dialer Consultant
email : marveelou@gmail.com
skype : marveelou
marveelou
 
Posts: 27
Joined: Thu Oct 02, 2014 8:38 pm
Location: Soong 2, Mactan , Cebu, Philippines

Re: calls not coming IN in agent..for predictive dialing

Postby williamconley » Fri May 06, 2022 3:00 pm

1) Welcome to the Party! 8-)

2) As you are obviously new here, I have some suggestions to help us all help you:

When you post, please post your entire configuration including (but not limited to) your installation method (7.X.X?) and vicidial version with build (VERSION: 2.X-XXXx ... BUILD: #####-####).

This IS a requirement for posting along with reading the stickies (at the top of each forum) and the manager's manual (available on EFLO.net, both free and paid versions)

You should also post: Asterisk version, telephony hardware (model number is helpful here), cluster information if you have one, and whether any other software is installed in the box. If your installation method is "manual/from scratch" you must post your operating system with version (and the .iso version from which you installed your original operating system) plus a link to the installation instructions you used. If your installation is "Hosted" list the site name of the host.

If this is a "Cloud" or "Virtual" server, please note the technology involved along with the version of that techology (ie: VMware Server Version 2.0.2). If it is not, merely stating the Motherboard model # and CPU would be helpful.

Similar to This:

Vicibox X.X from .iso | Vicidial X.X.X-XXX Build XXXXXX-XXXX | Asterisk X.X.X | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation | Intel DG35EC | Core2Quad Q6600

3) Your provided sample asterisk output contains no "dial" commands. When requesting help with an issue such as this, it is best to use a SINGLE TEST CALL example rather than a real-world multi-dial random extraction. It should be possible to follow the "agi, dial, hangup" dialplan progression from your carrier setup, which you also didn't post, but I digress:

4) Your assertion that "outbound is working" is in direct conflict to "when I enable auto-dialing no calls come to the agents". During installation, if you do not get calls with two-way sound to agents logged in to a campaign, your system is not yet functional. You could try to explain what you mean by "outbound is working", which may refer to manual dialing from the phones or agent screen manual dial page, of course.

5) If this is a brand new system and auto-dial has never worked, I *HIGHLY* recommend you either start at page one of the Vicidial Manager's Manual (free or paid version both work for this). Start at page one. Skip NOTHING. When you hit your first "it doesn't work perfectly" moment, post the page and line numbers from the manual, what you expected to happen, what really happened, and the relevent configuration settings and/or error messages. This will allow almost anyone with experience to walk you past this pothole and on to the next.

6) If your system has already been altered in ways not specified in the Vicidial Manger's Manual ... I recommend you just start over. It's free. And it'll make you much more comfortable with the installation process. Eventually you will need to be comfortable with installation and management of the system. The installation PDF and Vicidial Manager's Manual are designed to have everything you need to make this relatively pain-free in addition to "free like beer".

8-)
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: Vicidial Agent Only Beep - Beta
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19967
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 21 guests