Page 1 of 1

Asterisk versions supported by ViciDial

PostPosted: Fri Jul 16, 2010 5:01 pm
by mflorell
We get quite a few questions about what versions of Asterisk will work with ViciDial, and for support calls that we get this is often the problem with client systems if they did not use ViciBox or ViciDialNow to install their system(these come with tested versions of Asterisk).

For the 2.2.1 release and higher, we recommend Asterisk 1.4.21.2. We have also tested 1.4.27.1 and it appears to work rather well in production too.(1.4.21.1 is the last zaptel supported Asterisk version)

We have not bothered with supporting Asterisk 1.6 because it is already end-of-life, but we have recently added support for Asterisk 1.8. Currently we have tested with 1.8.21.0 and it has worked great so far.

UPDATE: We now include Asterisk 1.8 by default in our ViciBox ISO installer, Asterisk 1.8 is fully supported for Vicidial use.

UPDATE 2018-10-18: We now include Asterisk 13 by default in our ViciBox ISO installer, Asterisk 13 is fully supported and recommended for Vicidial use.


ViciDial will run with Asterisk 1.2.23 and higher as well, but for many reasons, like more features and better SIP support, we recommend the two 1.4 versions mentioned above.

Known broken Asterisk versions:
- 1.4.0 through 1.4.17
- 1.4.23
- 1.4.29 and 1.4.29.1

Re: Asterisk versions supported by ViciDial

PostPosted: Wed May 02, 2012 7:54 am
by cyrenity
And which asterisk versions are supported by vicidial 2.4?

Re: Asterisk versions supported by ViciDial

PostPosted: Wed May 02, 2012 11:48 am
by mflorell
same as listed above. We are working on Asterisk 1.8 support, but it will not be done and tested for a few months.

Re: Asterisk versions supported by ViciDial

PostPosted: Fri Aug 03, 2012 6:02 am
by stevejfice
Is there any update on 1.8 support? We would really like to upgrade our dialler platform to a later LTS version

Re: Asterisk versions supported by ViciDial

PostPosted: Fri Aug 03, 2012 7:24 am
by mflorell
We have done some work on 1.8, there are many core things that have changed, and we are working on handling them when we have time. We expect to be done with our work by the end of the year, then we will release a beta version that you can test.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Sep 11, 2012 8:11 am
by anikallembi
Hi all,
vici 2.1
version 2.4-309a
build:110430-1642
asterisk 1.4.39.1
from iso.
no extra hardware.
no addons.
using eybeam as a softphone.

A strange probleme accured today.

When i use the MANUAL DIAL MODE i can't dial the next number coz when i hungup that call and use one of the system status.when coming back ;the BOTTON DIAL NEXT is inactive and i have to logout and login again to dial the next number.

Help me Please....

Thnx !!

Re: Asterisk versions supported by ViciDial

PostPosted: Sat May 04, 2013 11:11 am
by lusybus
Hi,
I am new to the vicidial project I have just installed the VICIdial server as per the installation document of version vicibox v.4. I am unable to configure the digium card.

Please help me out to install the digium card on vicidial server.

Thanks in advance.

Vicibox V.4 from .iso | Vicidial 2.6-399a Build 130425-0700 | Asterisk 1.4.44-vici | Single Server |
Digium, Inc. Wildcard TE220 dual-span Hardware | No Extra Software After Installation | Intel(R) Pentium(R) Dual CPU E2160 @ 1.80GHz

Linux vici1 3.1.10-1.19-pae #1 SMP Mon Feb 25 10:32:50 UTC 2013 (f0b13a3) i686 i686 i386 GNU/Linux

Re: Asterisk versions supported by ViciDial

PostPosted: Mon May 06, 2013 11:01 am
by striker

Re: Asterisk versions supported by ViciDial

PostPosted: Mon May 06, 2013 9:14 pm
by williamconley
Please post the Version of your Vicibox installer .iso. Especially since this is an installer related question 8-)

Did you have the digium card installed before you began installation or did you put it in after?

If you don't have luck with striker's link ... consider asking digium. They are very useful and their systems are very asterisk friendly (since they own asterisk ... of course).

If all else fails, I've heard that GoAutoDial has a very friendly digium install but I've never tried it myself. I've always had best luck with Vicibox's installer (and we rarely use telephony hardware, as it is not required for VOIP which is where the best savings and system capacity are!).

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Feb 17, 2015 8:33 pm
by facePlanted
Hi, which asterisk versions works ok with ViciDial astguiclient_2.9rc1.zip ?

Re: Asterisk versions supported by ViciDial

PostPosted: Wed Feb 18, 2015 6:58 am
by mflorell
Asterisk 1.4 and 1.8. But there are known bugs in that version and I would recommend using the latest svn/trunk version instead.

Re: Asterisk versions supported by ViciDial

PostPosted: Wed Jun 03, 2015 12:21 pm
by bobchaos
with Asterisk 1.8 coming to EOL later this year, are there plans to move Vicidial towards a more recent version like 13?

Re: Asterisk versions supported by ViciDial

PostPosted: Thu Jun 04, 2015 6:30 am
by mflorell
Our next target is Asterisk 11, which would be the next long-term-release after Asterisk 1.8. We haven't started work on testing it yet, but we probably will later this summer.

Re: Asterisk versions supported by ViciDial

PostPosted: Thu Jul 09, 2015 9:49 pm
by fachryonline
does asterisk 11 support?

Re: Asterisk versions supported by ViciDial

PostPosted: Thu Jul 09, 2015 9:52 pm
by williamconley
fachryonline wrote:does asterisk 11 support?

Not yet.

Re: Asterisk versions supported by ViciDial

PostPosted: Fri Jul 10, 2015 6:24 am
by mflorell
We have been testing Vicidial with Asterisk 11 for the last several weeks. All of the major stuff works properly now in our testing setup, we are just making the last few tweaks to get all of the smaller features working properly(This week we just figured out an odd change they made in how new Music-on-hold contexts are recognized). Hopefully we'll have the code committed to Vicidial and a new Vicidial-approved tarball of Asterisk 11 out in the next few weeks.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Sep 15, 2015 8:54 am
by devafree
Where can one obtain asterisk-1.28.2-vici? I cannot seem to find a download link to it.

And, is this the latest Asterisk version recommended for fresh installation?

thanks in advance.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Sep 15, 2015 10:26 am
by mflorell
This topic has a link at the bottom to the first version of Asterisk 11 that we are testing with.

viewtopic.php?f=3&t=34545


We should have a more recent version out in the next couple weeks, and hopefully we will have Asterisk 11 as an option on Vicibox in a month or two.


As for right now, we recommend Asterisk 1.8 for use with Vicidial.

Re: Asterisk versions supported by ViciDial

PostPosted: Mon Sep 28, 2015 2:43 pm
by Marco Zink
devafree wrote:Where can one obtain asterisk-1.28.2-vici? I cannot seem to find a download link to it.

And, is this the latest Asterisk version recommended for fresh installation?

thanks in advance.


You can get Asterisk 1.8.23.0-vici from download[dot]vicidial[dot]com[slash]required-apps[slash]asterisk-1.8.23.0-vici.tar.gz

Sorry for the brackets, I can't paste a URL directly.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jan 24, 2017 2:17 am
by bobbymc
when do you guys plan to start working on asterisk 13? 11 will be EOL by the end of this year

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jan 24, 2017 6:54 am
by mflorell
We're working on it, but since they've completely rewritten the AMI, and deprecated some Asterisk CLI commands, it's going to be a while before it's ready for production. The developers have basically abandoned the idea of backward compatibility, so we have to adapt to all of their changes.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jan 24, 2017 10:00 am
by bobbymc
Can I help?

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jan 24, 2017 11:25 am
by mflorell
mcargile is the one doing most of the work. He's writing completely new versions of the update and listen scripts that only will work with Asterisk 13. Basically everything involving the AMI has to be rewritten. Not sure what you could help with at the moment, but when we have beta code to test we'll release it.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jan 24, 2017 8:32 pm
by bobbymc
Can I get a copy of what he has so far to test it with ?

Re: Asterisk versions supported by ViciDial

PostPosted: Fri Jan 27, 2017 6:28 am
by cissp009
is that possible for your guys to implement queue routing using asterisk either conference call for call routing.. because you guys are working on it right now for asterisk 13 AMI so that would be great if we consider this as well

Re: Asterisk versions supported by ViciDial

PostPosted: Fri Jan 27, 2017 1:51 pm
by williamconley
cissp009 wrote:is that possible for your guys to implement queue routing using asterisk either conference call for call routing.. because you guys are working on it right now for asterisk 13 AMI so that would be great if we consider this as well

If you were to sponsor such a request (in a different post, or directly with The Vicidial Group's sales staff ...), I'm sure they'd consider it. Otherwise, it's unlikely they'll be adding features while porting the system to a new version of Asterisk. One thing at a time. Delaying the asterisk version upgrade to add new features is counterproductive.

IE: Make a new post with the new request, and for Best Results sponsor the feature.

Re: Asterisk versions supported by ViciDial

PostPosted: Wed Aug 02, 2017 12:33 pm
by bobbymc
Any progress on asterisk 13 support and where can I get a copy of the scripts ?

Re: Asterisk versions supported by ViciDial

PostPosted: Wed Aug 02, 2017 12:54 pm
by mflorell
Yes, we are making progress with Asterisk 13, slowly. No scripts are available yet as they are frequently changing as we test compatibility.

Re: Asterisk versions supported by ViciDial

PostPosted: Sat Apr 07, 2018 11:33 pm
by kashinc
I was just wondering what version of asterisk would be considered most stable on the latest SVN trunk. I have been running 11.25-3 but still see a lot of people running 1.8.23-vici.

I was wondering what the advantages of 1.8.23 would be and if it's worth downgrading?

-kashinc

Re: Asterisk versions supported by ViciDial

PostPosted: Sun Apr 08, 2018 6:38 am
by williamconley
As long as you don't go up to Asterisk 13, all versions of Asterisk from 1.2 through 11 (1.2,1.4,1.6,1.8, 11) are virtually identical for Vicidial usage. There are no Asterisk features that affect how Vicidial runs. Vicidial uses PERL scripts to perform its magic and does not rely on Asterisk modules (at least not any that have had features removed).

Re: Asterisk versions supported by ViciDial

PostPosted: Sun Apr 08, 2018 8:35 am
by mflorell
For about a month now, all production clients of ours are having Asterisk 13 installed. It is able to handle higher call loads than previous versions, and is the only currently supported version of Asterisk that VICIdial is compatible with.

Re: Asterisk versions supported by ViciDial

PostPosted: Sun Apr 08, 2018 11:30 am
by williamconley
mflorell wrote:... the only currently supported version of Asterisk ...

... currently supported by The Vicidial Group, or currently supported by "Digium"?

Re: Asterisk versions supported by ViciDial

PostPosted: Sun Apr 08, 2018 12:00 pm
by mflorell
Asterisk 13 is the only VICIdial-compatible branch of Asterisk that is still being actively supported by Digium. In fact, Asterisk 13 is the only LTS(Long Term Support) Asterisk branch being supported by Digium right now. Both the Asterisk 14 & 15 branches are short-term support branches.

https://www.asterisk.org/downloads/aste ... k-versions

Re: Asterisk versions supported by ViciDial

PostPosted: Thu Oct 18, 2018 1:48 pm
by rameez.amjad4
is asterisk 1.8 supported with vicibox 8.1.2 ? If yes how can we rollback from default installed asterisk 13 to asterisk 1.8 please update, Thanks.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jul 02, 2019 1:38 pm
by rameez.amjad4
Good Day,
Just installed Vicibox 8.1.2 and after updated system installed asterisk 11 using this command as mentioned on installation manual

http://download.vicidial.com/iso/vicibo ... nstall.pdf

and after installing Vicibox-express on the system when i try to open asterisk using this command its giving the following error, i did installation 2 times but it gives same error, Please help, Thanks.

Error:
Unable to connect to remote asterisk (does /run/asterisk/asterisk.ctl exist?)

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jul 02, 2019 1:42 pm
by rameez.amjad4
This is error when i try to start asterisk:

/etc/init.d/asterisk status
Checking for asterisk dead
‚óŹ asterisk.service - Asterisk PBX
Loaded: loaded (/usr/lib/systemd/system/asterisk.service; disabled; vendor preset: disabled)
Active: inactive (dead)

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jul 02, 2019 2:16 pm
by williamconley
1) asterisk does not run as a service in vicidial.

2) NEVER use the EXPRESS installer. Use the standard. Express gets fixed last (although it usually works, lol), and it has no feedback if something does go wrong. And the standard is still very easy. It just has a quick quiz for "which items you want to install for this server".

3) If you want to troubleshoot asterisk, there should be a SCREEN with asterisk running. The keepalive script in the crontab for root should try to start asterisk if it is not running IF the setting to restart asterisk is active in admin->servers for that server. Otherwise, it should start with the other startup processes.

4) Or for troubleshooting, you can use
Code: Select all
/usr/sbin/asterisk -vvvvvvvvvvvvvvvvvvvvvgcT

And find what the problem is. However: That won't put it in the screen it needs to be in unless you actually execute it in the screen "screen -r asterisk" to attach to that screen.

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jul 16, 2019 3:21 pm
by mdshams
Hi every one

I have installed a vicidial 7.0.0_V and trying to install codec_g792, but i have tried all codec which i have every time i have tried to put codec asterisk got stopped and when ever try to connect asterisk in putty getting mgs unavailable to connect asterisk , the i tried every possible things as per my knowledge, but asterisk were not starting so have format again and again. now i am not trying to put codec_g729, because againg asterisk will stop, so can you guys help me that what codec will support in my dialer. and provide me the codec also please
dialer version is below
vicidial 7.0.0_V
Asterisk Version: 11.20.0-vici

Re: Asterisk versions supported by ViciDial

PostPosted: Tue Jul 16, 2019 4:46 pm
by williamconley
mdshams wrote:Hi every one

I have installed a vicidial 7.0.0_V and trying to install codec_g792, but i have tried all codec which i have every time i have tried to put codec asterisk got stopped and when ever try to connect asterisk in putty getting mgs unavailable to connect asterisk , the i tried every possible things as per my knowledge, but asterisk were not starting so have format again and again. now i am not trying to put codec_g729, because againg asterisk will stop, so can you guys help me that what codec will support in my dialer. and provide me the codec also please
dialer version is below
vicidial 7.0.0_V
Asterisk Version: 11.20.0-vici


1) Welcome to the Party! 8-)

2) As you are obviously new here, I have some suggestions to help us all help you:

When you post, please post your entire configuration including (but not limited to) your installation method (7.X.X?) and vicidial version with build (VERSION: 2.X-XXXx ... BUILD: #####-####).

This IS a requirement for posting along with reading the stickies (at the top of each forum) and the manager's manual (available on EFLO.net, both free and paid versions)

You should also post: Asterisk version, telephony hardware (model number is helpful here), cluster information if you have one, and whether any other software is installed in the box. If your installation method is "manual/from scratch" you must post your operating system with version (and the .iso version from which you installed your original operating system) plus a link to the installation instructions you used. If your installation is "Hosted" list the site name of the host.

If this is a "Cloud" or "Virtual" server, please note the technology involved along with the version of that techology (ie: VMware Server Version 2.0.2). If it is not, merely stating the Motherboard model # and CPU would be helpful.

Similar to This:

Vicibox X.X from .iso | Vicidial X.X.X-XXX Build XXXXXX-XXXX | Asterisk X.X.X | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation | Intel DG35EC | Core2Quad Q6600

3) Please do not hijack another thread for your own devious purposes. Create your own. We don't charge "per thread" (this site is free!). Either comment on a thread directly related to your issue OR create your own post entirely.

4) g729 is not a "Vicidial" codec. Because there are NO vicidial codecs. Vicidial controls the Asterisk PBX engine. Asterisk has codecs. So you would do much better to go one of two ways:
a) Locate a forum that has information on how to load the proper codecs into Asterisk. You obviously know your Asterisk version, which is half of the information you need. The other half is the physical CPU architecture. The sites that have g729 available will generally have g729 sorted into the required architecture and asterisk version and may even have instructions on the method. However: This is an Asterisk question and there are a lot more active asterisk forum sites and users than there are Vicidial sites and users.
b) or re-install with Vicibox 8.1.2, which now has an optional g729 installation option because g729 licensing is now free (it could not be included before because it was not free).

5) In all cases: Next time start with the full information required (and hopefully also the optional information) and create your own thread or actually list your question in a thread regarding g729 installation on Vicidial. This thread is entitled "asterisk versions supported by Vicidial". Not related to g729 at all. So don't have the conversation here to avoid muddying up this thread. Online Etiquette. 8-)