Randomly call recordings not happening

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Randomly call recordings not happening

Postby santhuarnold » Wed Nov 22, 2017 5:46 am

Hi,
We are having issue with vicidial multiple call recording missing (not happening) randomly, campaign call recording set to FORCE, still calls are missing.
the recording file name and link is not creating.
Not getting any error in logs to identify, kindly help us to fix the issue.


ViciBox Redux v.6.0.4 | VERSION: 2.12-549a | BUILD: 160404-0940 | Asterisk 1.8.32.3-vici

logs:

[Nov 20 10:55:07] VERBOSE[49129] pbx.c: [Nov 20 10:55:07] -- Executing [8600082@default:1] MeetMe("Local/8600082@default-0000cde1;2", "8600082,F") in new stack
[Nov 20 10:55:07] VERBOSE[49128] pbx.c: [Nov 20 10:55:07] > Channel Local/8600082@default-0000cde1;1 was answered.
[Nov 20 10:55:07] VERBOSE[49130] pbx.c: [Nov 20 10:55:07] -- Executing [69906592255@default:1] AGI("Local/8600082@default-0000cde1;1", "agi://127.0.0.1:4577/call_log") in new stack
[Nov 20 10:55:07] VERBOSE[49130] res_agi.c: [Nov 20 10:55:07] -- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=VER_CARS))
[Nov 20 10:55:07] VERBOSE[49130] res_agi.c: [Nov 20 10:55:07] -- <Local/8600082@default-0000cde1;1>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
[Nov 20 10:55:07] VERBOSE[49130] pbx.c: [Nov 20 10:55:07] -- Executing [69906592255@default:2] Dial("Local/8600082@default-0000cde1;1", "SIP/9906592255@nwpri,,To") in new stack
[Nov 20 10:55:07] VERBOSE[49130] netsock2.c: [Nov 20 10:55:07] == Using SIP RTP CoS mark 5
[Nov 20 10:55:07] VERBOSE[49130] app_dial.c: [Nov 20 10:55:07] -- Called SIP/9906592255@nwpri
[Nov 20 10:55:07] VERBOSE[25564] netsock2.c: [Nov 20 10:55:07] == Using SIP RTP CoS mark 5
[Nov 20 10:55:08] VERBOSE[49130] app_dial.c: [Nov 20 10:55:08] -- SIP/nwpri-0000a8ec is ringing
[Nov 20 10:55:08] VERBOSE[49130] app_dial.c: [Nov 20 10:55:08] -- SIP/nwpri-0000a8ec is making progress passing it to Local/8600082@default-0000cde1;1
[Nov 20 10:55:08] VERBOSE[49128] manager.c: [Nov 20 10:55:08] == Manager 'sendcron' logged off from 127.0.0.1
[Nov 20 10:55:50] VERBOSE[49129] pbx.c: [Nov 20 10:55:50] -- Executing [h@default:1] AGI("Local/8600082@default-0000cde1;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------") in new stack
[Nov 20 10:55:50] VERBOSE[49129] res_agi.c: [Nov 20 10:55:50] -- <Local/8600082@default-0000cde1;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ---------- completed, returning 0
[Nov 20 10:55:50] VERBOSE[49130] pbx.c: [Nov 20 10:55:50] == Spawn extension (default, 69906592255, 2) exited non-zero on 'Local/8600082@default-0000cde1;1'
[Nov 20 10:55:50] VERBOSE[49130] pbx.c: [Nov 20 10:55:50] -- Executing [h@default:1] AGI("Local/8600082@default-0000cde1;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0-----CANCEL----------") in new stack
[Nov 20 10:55:50] VERBOSE[49130] res_agi.c: [Nov 20 10:55:50] -- <Local/8600082@default-0000cde1;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ---------- completed, returning 0
[Nov 20 10:55:50] VERBOSE[49325] manager.c: [Nov 20 10:55:50] == Manager 'sendcron' logged on from 127.0.0.1
[Nov 20 10:55:50] VERBOSE[49182] manager.c: [Nov 20 10:55:50] == Manager 'sendcron' logged off from 127.0.0.1
santhuarnold
 
Posts: 76
Joined: Mon Sep 02, 2013 7:32 am

Re: Randomly call recordings not happening

Postby blackbird2306 » Wed Nov 22, 2017 9:41 am

How is your system load when this happens? Might be an overloading or network issue. Try the "Routing Initiated Recording=Y" and "Campaign Recording=ALLFORCE" in campaign settings. And please upgrade your system. There was a recent post regarding this problem:

http://www.vicidial.org/VICIDIALforum/viewtopic.php?f=4&t=36151
Vicibox 6.0.2 from Vicibox_v.6.0.x86_64-6.0.2.iso | Vicidial 2.12-560a build: 160617-1427 | Asterisk 1.8.32.3
blackbird2306
 
Posts: 349
Joined: Mon Jun 23, 2014 5:31 pm

Re: Randomly call recordings not happening

Postby santhuarnold » Fri Nov 24, 2017 12:47 am

Load average is 2.52 2.50
Dedicated 100 MBPs managed switch using.
The server hardware is Intel(R) Xeon(R) CPU E5-2620 v4 @ 2.10GHz, 24 core, 64 GB RAM.

We have not faced this issue before. is there any way to get the reason for this issue?

Thanks
santhuarnold
 
Posts: 76
Joined: Mon Sep 02, 2013 7:32 am

Re: Randomly call recordings not happening

Postby santhuarnold » Tue Nov 28, 2017 6:20 am

anyone has fix for this?
if you have kindly help me.

Thanks
Santhosh
ViciBox v.7.0.1| Asterisk 11.21.0-vici | VERSION: 2.12-546a | BUILD: 160328-0316
santhuarnold
 
Posts: 76
Joined: Mon Sep 02, 2013 7:32 am

Re: Randomly call recordings not happening

Postby mflorell » Tue Nov 28, 2017 7:08 am

Have you tried turning on Routing Initiated Recording in your campaigns and in-groups?

The cause of this is often lost packets from the agent screen, and is often a symptom of network problems. It can also happen when a system gets overloaded.
mflorell
Site Admin
 
Posts: 17040
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida


Return to Support

Who is online

Users browsing this forum: Google [Bot] and 24 guests