Call Answer Detection issue with FXO Card

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Call Answer Detection issue with FXO Card

Postby pargat » Tue Dec 26, 2017 5:26 am

Hi,

I have setup a new vicidial setup from the latest vicibox iso (vicibox-8). VERSION: 2.14-639a BUILD: 171028-0913 Asterisk 11.25.3-vici. Am using a Sangoma A200 with 4 Fxo ports for inbound and out bound calls.

The system is working fine on manual dial mode and am able to receive calls as well. The issue wis with Auto dial calls

On Auto dial mode (predictive dialing) am unable to get the call answer being detected by the system. Even when the call is answered by the called party, the agent does not get anything and there is no detection on the CLI interface as well. On manual dial the agent can hear the call ringing and call answer and can talk to the called party.

Is there anyway this can be fixed?

My chan_dahdi.conf already has the following:
Code: Select all
relaxdtmf=yes
usedistinctiveringdetection=no
hanguponpolarityswitch=yes
answeronpolarityswitch=yes
useincomingcalleridondahditransfer=yes
cidstart=ring
callerid=asreceived


thanks for the support!
pargat
 
Posts: 36
Joined: Mon Jun 20, 2011 4:25 am

Re: Call Answer Detection issue with FXO Card

Postby mflorell » Tue Dec 26, 2017 8:43 am

This is a known issue with FXO/FXS cards in Asterisk. There is no fix for this other than possibly switching to other external SIP gateway hardware that does a better job at answer detection.
mflorell
Site Admin
 
Posts: 17040
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida


Return to Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], prosoft and 23 guests