Using the VM button to leave message on answering machine

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Using the VM button to leave message on answering machine

Postby dspaan » Fri Sep 28, 2018 7:31 am

I have setup a campaign where in the campaign details i specified a file in the 'Answering Machine Message' field.

I dialed my own mobile phone where i activated voicemail. When i leave a message the normal way i get my voicemail.

But i want to use the VM button in the Transfer conf panel, but when i use that i don't get a voicemail message. Here is some output from the console:

This is a manual outbound call via the agent screen:
Code: Select all
[Sep 28 14:21:34] =========================================================================
[Sep 28 14:21:34] Connected to Asterisk 11.25.3-vici currently running on demo (pid = 2143)
[Sep 28 14:21:46]     -- Executing [8600051@default:1] MeetMe("Local/8600051@default-000001c4;2", "8600051,F") in new stack
[Sep 28 14:21:46]        > Channel Local/8600051@default-000001c4;1 was answered
[Sep 28 14:21:46]     -- Executing [***********@default:1] AGI("Local/8600051@default-000001c4;1", "agi://127.0.0.1:4577/call_log") in new stack
[Sep 28 14:21:46]     -- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=DEMO6))
[Sep 28 14:21:46]     -- <Local/8600051@default-000001c4;1>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
[Sep 28 14:21:46]     -- Executing [***********@default:2] Dial("Local/8600051@default-000001c4;1", "SIP/fluxfreetrial/31***********,,To") in new stack
[Sep 28 14:21:46]   == Using SIP RTP CoS mark 5
[Sep 28 14:21:46]     -- Called SIP/fluxfreetrial/31***********
[Sep 28 14:21:47]     -- Executing [58600051@default:1] MeetMe("Local/58600051@default-000001c5;2", "8600051,Fmq") in new stack
[Sep 28 14:21:47]        > Channel Local/58600051@default-000001c5;1 was answered
[Sep 28 14:21:47]     -- Executing [8309@default:1] Answer("Local/58600051@default-000001c5;1", "") in new stack
[Sep 28 14:21:47]     -- Executing [8309@default:2] Monitor("Local/58600051@default-000001c5;1", "wav,20180928-142146_***********") in new stack
[Sep 28 14:21:47]     -- Executing [8309@default:3] Wait("Local/58600051@default-000001c5;1", "3600") in new stack
[Sep 28 14:21:49]        > 0x7f88f80155d0 -- Strict RTP learning after remote address set to: 185.47.2.103:13052
[Sep 28 14:21:49]     -- SIP/fluxfreetrial-00000177 is making progress passing it to Local/8600051@default-000001c4;1
[Sep 28 14:21:49]        > 0x7f88f80155d0 -- Strict RTP switching to RTP remote address 185.47.2.103:13052 as source
[Sep 28 14:21:51]        > 0x7f88f80155d0 -- Strict RTP learning complete - Locking on source address 185.47.2.103:13052
[Sep 28 14:21:58]     -- SIP/fluxfreetrial-00000177 answered Local/8600051@default-000001c4;1


This is where i leave the message, you can see the message is played:
Code: Select all
[Sep 28 14:22:13]     -- Executing [h@default:1] AGI("Local/8600051@default-000001c4;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----27-----15") in new stack
[Sep 28 14:22:13]     -- Executing [8320*DEMO6*31*6************53011@default:1] AGI("SIP/fluxfreetrial-00000177", "VD_amd.agi,8320*DEMO6*31*6************53011-----YES") in new stack
[Sep 28 14:22:13]     -- Launched AGI Script /usr/share/asterisk/agi-bin/VD_amd.agi
[Sep 28 14:22:13]     -- <Local/8600051@default-000001c4;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----27-----15 completed, returning 0
[Sep 28 14:22:13]   == Spawn extension (default, 531620243061, 2) exited non-zero on 'Local/8600051@default-000001c4;1'
[Sep 28 14:22:13]   == Spawn extension (default, 8600051, 1) exited non-zero on 'Local/8600051@default-000001c4;2'
[Sep 28 14:22:13]     -- Executing [h@default:1] AGI("Local/8600051@default-000001c4;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------") in new stack
[Sep 28 14:22:13]     -- <Local/8600051@default-000001c4;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------- completed, returning 0
[Sep 28 14:22:13]     -- Manager 'sendcron' from 127.0.0.1, hanging up channel: Local/58600051@default-000001c5;2
[Sep 28 14:22:13]   == Spawn extension (default, 58600051, 1) exited non-zero on 'Local/58600051@default-000001c5;2'
[Sep 28 14:22:13]     -- Executing [h@default:1] AGI("Local/58600051@default-000001c5;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------") in new stack
[Sep 28 14:22:13]     -- <Local/58600051@default-000001c5;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------- completed, returning 0
[Sep 28 14:22:13]   == Spawn extension (default, 8309, 3) exited non-zero on 'Local/58600051@default-000001c5;1'
[Sep 28 14:22:13]     -- Executing [h@default:1] AGI("Local/58600051@default-000001c5;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------") in new stack
[Sep 28 14:22:13]     -- <Local/58600051@default-000001c5;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------- completed, returning 0
[Sep 28 14:22:13]     -- <SIP/fluxfreetrial-00000177> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
[Sep 28 14:22:13]     -- <SIP/fluxfreetrial-00000177> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
[Sep 28 14:22:13]     -- <SIP/fluxfreetrial-00000177> Playing 'Telforce_announce.slin' (escape_digits=) (sample_offset 0) (language 'en')
[Sep 28 14:22:15]     -- <SIP/fluxfreetrial-00000177>AGI Script VD_amd.agi completed, returning 4
[Sep 28 14:22:15]   == Spawn extension (default, 8320*DEMO6*31*6************53011, 1) exited non-zero on 'SIP/fluxfreetrial-00000177'
[Sep 28 14:22:15]     -- Executing [h@default:1] AGI("SIP/fluxfreetrial-00000177", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------") in new stack
[Sep 28 14:22:15]     -- <SIP/fluxfreetrial-00000177>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------- completed, returning 0

Note: I replaced my phonenumber with ***********

Do i need to configure anything else to make this work?
Regards, Dennis

Vicibox 8.0.1
Version: 2.14b0.5
SVN Version: 2951
DB Schema Version: 1540
dspaan
 
Posts: 1000
Joined: Fri Aug 21, 2009 1:40 pm
Location: The Netherlands

Re: Using the VM button to leave message on answering machin

Postby dspaan » Fri Sep 28, 2018 8:05 am

Never mind, it's working now but wasn't before.
Regards, Dennis

Vicibox 8.0.1
Version: 2.14b0.5
SVN Version: 2951
DB Schema Version: 1540
dspaan
 
Posts: 1000
Joined: Fri Aug 21, 2009 1:40 pm
Location: The Netherlands


Return to Support

Who is online

Users browsing this forum: Majestic-12 [Bot], rickytrix and 20 guests