DTMF Issue

All installation and configuration problems and questions

Moderators: Kumba, mflorell, williamconley, enjay, Michael_N, Staydog, gardo, Op3r, gerski, mcargile

DTMF Issue

Postby brainwhistler » Mon Jun 02, 2008 5:44 am

I have single server setup with :

Asterisk 1.2.27
ViciDial 2.0.4.1rc2

The only Trunk i have is SIP VoIP on G.729 codec. The problem is that my agent cannot pass DTMF on IVR's, or more clearly DTMF does not work at all. The CLI output is :


localhost*CLI>
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
-- Executing Answer("Local/8500998@default-a34c,2", "") in new stack
-- Executing Playback("Local/8500998@default-a34c,2", "silence") in new stack
-- Playing 'silence' (language 'en')
> Channel Local/8500998@default-a34c,1 was answered.
-- Executing MeetMe("Local/8500998@default-a34c,1", "8600074|q") in new stack
Jun 2 04:13:18 WARNING[11790]: file.c:1045 ast_waitstream: Unexpected control subclass '-1'
-- Executing AGI("Local/8500998@default-a34c,2", "agi-dtmf.agi") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/agi-dtmf.agi
== Manager 'sendcron' logged off from 127.0.0.1
-- AGI Script agi-dtmf.agi completed, returning 0
-- Executing Hangup("Local/8500998@default-a34c,2", "") in new stack
== Spawn extension (default, 8500998, 4) exited non-zero on 'Local/8500998@default-a34c,2'
-- Executing DeadAGI("Local/8500998@default-a34c,2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16---------------)") in new stack
-- AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ----------) completed, returning 0
== Spawn extension (default, 78600074, 1) exited non-zero on 'Local/8500998@default-a34c,1'
-- Executing DeadAGI("Local/8500998@default-a34c,1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------)") in new stack
-- AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ----------) completed, returning 0
localhost*CLI>



Any idea how to resolve this issue.

thanks
brainwhistler
 
Posts: 36
Joined: Fri Feb 08, 2008 10:52 am

Postby mflorell » Mon Jun 02, 2008 6:27 am

Do you have the dtmf passthru patch applied to Asterisk?

Are you using the F flag when calling meetme in your dialplan?
mflorell
Site Admin
 
Posts: 13932
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Postby brainwhistler » Mon Jun 02, 2008 6:52 am

yes patch is applied.

I thought F flag was only for Zap calls not for VoIP as posted somewhere at the forum..... please advise....!!!
brainwhistler
 
Posts: 36
Joined: Fri Feb 08, 2008 10:52 am

Postby mflorell » Mon Jun 02, 2008 4:09 pm

F flag is for all channels in meetme to allow DTMF to pass through freely.
mflorell
Site Admin
 
Posts: 13932
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Postby brainwhistler » Tue Jun 03, 2008 12:48 am

I tried with F Flag and without the Flag, the send DTMF is discarding the first digit.

Don't know why.... any idea ??? The CLI output is the same i posted earlier.

thanks
brainwhistler
 
Posts: 36
Joined: Fri Feb 08, 2008 10:52 am

Postby mflorell » Tue Jun 03, 2008 4:39 am

Does it work better if you put a comma before the first digit?
mflorell
Site Admin
 
Posts: 13932
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Postby brainwhistler » Tue Jun 03, 2008 6:40 am

Yeah, placing a comma before first digit really works. But it takes almost 2 seconds to pass the DTMF. Is there any way to reduce it to one second.

Also, explaining an agent why should he puts a comma before he send the digits is too difficult. Can we do this automated.

Thanks
brainwhistler
 
Posts: 36
Joined: Fri Feb 08, 2008 10:52 am

Postby brainwhistler » Tue Jun 03, 2008 6:56 am

Its also working without F flag when calling meetme.
brainwhistler
 
Posts: 36
Joined: Fri Feb 08, 2008 10:52 am

Postby mflorell » Tue Jun 03, 2008 8:37 am

You could add the comma to the code of the dtmf AGI script, then it would add it for every time it is run.
mflorell
Site Admin
 
Posts: 13932
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida


Return to Support

Who is online

Users browsing this forum: darkng and 3 guests