Version 4(preview) initial installation HOWTO (from scratch)

General and Support topics relating to ViciDialNow and GoAutoDial ISO installers

Moderators: enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, s0lid

Version 4(preview) initial installation HOWTO (from scratch)

Postby gardo » Mon Aug 13, 2018 12:45 pm

After almost 3 years of heavy development, GOautodial app version 4 (preview version) is just around the corner. Here's the initial installation (from scratch) HOWTO: https://goautodial.org/projects/goautod ... _CentOS_7X.

Warning: Not for the faint of heart. :)

Technology:

Bootstrap 3
WebRTC
HTML5
JQuery
Asterisk 13
Vicidial SVN
Kamailio 5
CreamyCRM
OSticket
GOautodial v4

Some screenies;

Image

Image
http://goautodial.com
Empowering the next generation contact centers
gardo
 
Posts: 1926
Joined: Fri Sep 15, 2006 10:24 am
Location: Manila, 1004

Re: Version 4(preview) initial installation HOWTO (from scra

Postby Acidshock » Wed Sep 05, 2018 3:52 pm

Damn its looking awfully sexy. Can it run along side the regular interface? What other advantages and changes? Any core modifications to the way Vicidial works?
VERSION: 2.14-698a | BUILD: 190207-2301 | Asterisk:13.24.1-vici | Vicibox 8.1.2
Acidshock
 
Posts: 397
Joined: Wed Mar 03, 2010 3:19 pm

Re: Version 4(preview) initial installation HOWTO (from scra

Postby Acidshock » Wed Sep 05, 2018 3:59 pm

Oh and why is Kamalio being used?
VERSION: 2.14-698a | BUILD: 190207-2301 | Asterisk:13.24.1-vici | Vicibox 8.1.2
Acidshock
 
Posts: 397
Joined: Wed Mar 03, 2010 3:19 pm

Re: Version 4(preview) initial installation HOWTO (from scra

Postby dspaan » Tue Oct 02, 2018 2:37 pm

I thought it would be fun to install this new Goautodial release but it seems the guide was based on a different base installation of Goautodial. The guide says Install GOautodial version 3.X (either from scratch or using the v3.3 ISO. I used this guide to install Goautodial 3.0 first: https://goautodial.org/projects/goautod ... ed_Guidev3

But from that point forward the guide does not apply to the system you get when you install Goautodial 3.0:

the default mysql password is 'vicidialnow'
the correct command to shutdown asterisk is asterisk -rx "core stop now"
the correct command to shutdown apache is service httpd stop

I tried to uninstall php but when i install from the goautodial 3 ISO this is the php version that is installed and the output i get when trying to uninstall:

Code: Select all
[root@autodial yum.repos.d]# rpm -qa | grep php
phpsysinfo-2.5.4-1.vnow
php-cli-5.3.22-1.w5
php-mbstring-5.3.22-1.w5
php-gd-5.3.22-1.w5
php-pear-1.4.9-8.el5
phpmyadmin-2.11.11.3-2.el5.rf
php-common-5.3.22-1.w5
php-pdo-5.3.22-1.w5
php-mcrypt-5.3.22-1.w5
php-eaccelerator-0.9.6.1-1.1.w5
php-imap-5.3.22-1.w5
php-devel-5.3.22-1.w5
php-mysql-5.3.22-1.w5
php-5.3.22-1.w5
[root@autodial yum.repos.d]# rpm -e phpsysinfo-2.5.4-1.vnow php-cli-5.3.22-1.w5 php-mbstring-5.3.22-1.w5 php-gd-5.3.22-1.w5 php-pear-1.4.9-8.el5 phpmyadmin-2.11.11.3-2.el5.rf php-common-5.3.22-1.w5 php-pdo-5.3.22-1.w5 php-mcrypt-5.3.22-1.w5 php-eaccelerator-0.9.6.1-1.1.w5 php-imap-5.3.22-1.w5 php-devel-5.3.22-1.w5 php-mysql-5.3.22-1.w5 php-5.3.22-1.w5
error: Failed dependencies:
        phpsysinfo is needed by (installed) goautodial-ce-config-3.3-1.noarch
        php-cli is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-mbstring is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-gd is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-pear is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        phpmyadmin is needed by (installed) goautodial-ce-config-3.3-1.noarch
        php-pdo is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-mcrypt is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-eaccelerator is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-imap is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-devel is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php-mysql is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        php is needed by (installed) goautodial-ce-3.3-1406088000.noarch




Goautodial 3 has asterisk 1.8 and not 1.11:

Code: Select all
[root@autodial yum.repos.d]# rpm -qa | grep asterisk
asterisk-sounds-core-en-gsm-1.4.21-1_centos5.go
asterisk-core-1.8.23.0-1_centos5.go
asterisk-voicemail-1.8.23.0-1_centos5.go
asterisk-1.8.23.0-1_centos5.go
asterisk-perl-0.08-1.go
asterisk-configs-1.8.23.0-1_centos5.go
asterisk-doc-1.8.23.0-1_centos5.go
asterisk-dahdi-1.8.23.0-1_centos5.go


[root@autodial yum.repos.d]# rpm -e asterisk-1.8.23.0-1_centos5.go
error: Failed dependencies:
        asterisk >= 1.8 is needed by (installed) vicidial-2.9.441a-140612.1628.2.go.noarch
        asterisk is needed by (installed) asterisk-perl-0.08-1.go.x86_64
        asterisk >= 1.8 is needed by (installed) goautodial-ce-config-3.3-1.noarch



When updating i also get an error:

Code: Select all
[root@autodial www]# yum install -y epel-release
Loaded plugins: fastestmirror, security
Repository goautodial-current is listed more than once in the configuration
Repository goautodial-updates is listed more than once in the configuration
Determining fastest mirrors
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
 Eg. Invalid release/repo/arch combination/
removing mirrorlist with no valid mirrors: /var/cache/yum/base/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: base




this is what i have in /etc/yum.repos.d/goautodial.repo:

Code: Select all
[goautodial-current]
name=CentOS-$releasever - Goautodial - Current
baseurl=http://downloads2.goautodial.org/centos/$releasever/current/$basearch/
enabled=1
gpgcheck=0

[goautodial-updates]
name=CentOS-$releasever - Goautodial - Updates
baseurl=http://downloads2.goautodial.org/centos/$releasever/updates/$basearch/
enabled=1
gpgcheck=0



I had two repo files for goautodial:

GOautodial.repo
goautodial.repo

After removing one of them i still get this error:

Code: Select all
yum install -y epel-release
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
 Eg. Invalid release/repo/arch combination/
removing mirrorlist with no valid mirrors: /var/cache/yum/base/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: base
Regards, Dennis

Vicibox 8.1.2
Version: 2.14-717a
SVN Version: 3129
DB Schema Version: 1574
Build: 190724-1603
dspaan
 
Posts: 1298
Joined: Fri Aug 21, 2009 1:40 pm
Location: The Netherlands

Re: Version 4(preview) initial installation HOWTO (from scra

Postby cavagnaro » Mon Mar 18, 2019 8:41 pm

What is the Kamailio role? Why not use Asterisk in front directly?
cavagnaro
 
Posts: 38
Joined: Thu Feb 28, 2019 1:39 pm

Re: Version 4(preview) initial installation HOWTO (from scra

Postby williamconley » Mon Mar 18, 2019 8:51 pm

cavagnaro wrote:What is the Kamailio role? Why not use Asterisk in front directly?

that's my recommendation. use kamilio if you need it for billing or something else, but if you don't have a special reason for it just use asterisk
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19484
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciDialNow - GoAutoDial

Who is online

Users browsing this forum: No registered users and 18 guests