asterisk version after vicibox 7.0.3 install

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

asterisk version after vicibox 7.0.3 install

Postby rockgeneral » Wed Dec 21, 2016 3:55 pm

I just installed vicidial using the vicibox 7.0.3 iso. I used the express install method. I am getting a command time-out when the system runs /usr/share/astguiclient/AST_vm_update.pl. It is happening at line 210. In researching this problem I found a post that suggested taking a look at the asterisk version installed vs what is listed in the Amin interface in the Servers record.

The Asterisk Version field in the Servers record currently states:
1.4.21.2

Output from 'core show version':
Asterisk 11.25.1-vici built by abuild @ cloud113 on a x86_64 running Linux on 2016-12-19 21:19:40 UTC

Based on the output of core show version, what is the proper value for me to put in the Asterisk Version field in the Servers record? Sorry if this seems obvious but I do not want to assume.

Regards,

rockgeneral
Vicibox 7.0.3 | Vicidial 2.14b0.5 Build 2649 | Asterisk 11.25.1-vici (output of 'core show version') | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation
rockgeneral
 
Posts: 16
Joined: Thu Mar 04, 2010 9:28 pm

Re: asterisk version after vicibox 7.0.3 install

Postby rockgeneral » Wed Dec 21, 2016 4:29 pm

I decided to go with my intuition and change the Asterisk Version field in the Servers record as follows:

11.25.1-vici

Hooray!!! The vm script now runs! I'm not sure why the vicibox install would set the value to 1.4.21.2 when it was installing a different version, but alls well that ends well I suppose.

Cheers,

rockgeneral
Vicibox 7.0.3 | Vicidial 2.14b0.5 Build 2649 | Asterisk 11.25.1-vici (output of 'core show version') | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation
rockgeneral
 
Posts: 16
Joined: Thu Mar 04, 2010 9:28 pm

Re: asterisk version after vicibox 7.0.3 install

Postby Kumba » Wed Dec 21, 2016 5:42 pm

I'll have to duplicate it and see what is causing that. Perhaps something updated in the database and the SQL that sets that is error'ing out now.

Fun fun.

I guess It's time I push out a ViciBox v.7.0.4 anyways.
Kumba
 
Posts: 594
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: asterisk version after vicibox 7.0.3 install

Postby Kumba » Tue Jan 03, 2017 4:37 pm

There was an issue with the Asterisk 11 package. Running it would cause an illegal instruction issue which never output the asterisk version. I've since triggered a recompile and it is good now.
Kumba
 
Posts: 594
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 1 guest