Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo devic

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo devic

Postby sue136 » Wed Nov 07, 2018 5:44 pm

I have been using Vicibox 7.0.3-160505 as a standalone server for about 2 years as a single server load on a computer on my local network. It has been working well for me.

I want to update, so on different test computers I have been trying to install Vicibox 8.1.2 as a standalone server.

I downloaded the Vicibox 8.1.2 iso on 11/1/2018, - ViciBox v.8.1.2 181002 (Suse 42.3) , Asterisk 13.21.1-vici,

I do not have any DID cards/hardware installed on the server. I make calls by connecting to the asterisk standalone server with X-Lite softphone on my Windows computer.

I got a stock single server install to work with a test outbound campaign, test user group, test user, and was able to make a manual outbound call using X-Lite softphone. I made a backup of the computer using Clonezilla. Then I tried bringing over the data from my old computer (without doing an upgrade) to see what would happen. It did not work correctly, since I did not go through the update process. So I restored to my earlier clonezilla backup of the new test server.

BTW, after restoring with Clonezilla it would only boot into grub>. So I used information I found in a YouTube video to restore the grub using the Vicibox 8.1.2 live USB stick that I had originally used to load the computer.

https://www.youtube.com/watch?v=i5yUfPtruIg

So then it booted regularly. However when I try to login as a user using X-Lite, I do not hear the message “you are currently the only person in this conference” and I hear the disconnect/hangup sound and I get a message in my browser telling me to try to connect again or Go Back.

Then I also tried re-installing from scratch the other day using the Vicibox 8.1.2 live USB stick, but it is still doing the same thing where I cannot login as an agent using X-Lite. During the first installation process I did issue the command “zypper up -r”

I brought up the verbose mode (asterisk -vvvvvr) and saw the following errors when I tried to login from X-Lite:

# asterisk -vvvvvvvr

[Nov 5 17:00:30] -- Unregistered SIP '201'
[Nov 5 17:00:51] -- Registered SIP '201' at 192.168.99.96:55832
[Nov 5 17:00:51] NOTICE[5809]: chan_sip.c:24639 handle_response_peerpoke: Peer '201' is now Reachable. (5ms / 2000ms)
[Nov 5 17:00:52] -- Unregistered SIP '201'
[Nov 5 17:00:52] -- Registered SIP '201' at 192.168.99.96:55832
[Nov 5 17:01:01] == Manager 'sendcron' logged on from 127.0.0.1
[Nov 5 17:01:08] == Using SIP RTP CoS mark 5
[Nov 5 17:01:08] -- Called 201
[Nov 5 17:01:08] -- SIP/201-00000004 is ringing
[Nov 5 17:01:20] > 0x7f4e94008070 -- Strict RTP learning after remote address set to: 192.168.99.96:53970
[Nov 5 17:01:20] -- SIP/201-00000004 answered
[Nov 5 17:01:20] -- Executing [8600051@default:1] MeetMe("SIP/201-00000004", "8600051,F") in new stack
[Nov 5 17:01:20] WARNING[12615][C-00000007]: app_meetme.c:1657 build_conf: Unable to open DAHDI pseudo device
[Nov 5 17:01:20] == Spawn extension (default, 8600051, 1) exited non-zero on 'SIP/201-00000004'
[Nov 5 17:01:20] -- Executing [h@default:1] AGI("SIP/201-00000004", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------SIP 200 OK)") in new stack
[Nov 5 17:01:20] -- <SIP/201-00000004>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... -------SIP 200 OK) completed, returning 0
[Nov 5 17:01:21] == Manager 'sendcron' logged off from 127.0.0.1
vicibox81*CLI>


I would appreciate if anyone can let me know how to correct this issue or if I need to provide any other information. I have been pleased with Vicibox 7 but when I was able to make a text manual call using Vicibox 8 the call quality was much better, so I would like to use the latest version.
sue136
 
Posts: 5
Joined: Mon Nov 05, 2018 9:07 pm

Re: Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo d

Postby sue136 » Wed Nov 07, 2018 5:46 pm

I read some older posts I found through Google searches at http://www.eflo.net/VICIDIALforum/viewt ... =4&t=35743 about someone having similar problem with Unable to open DAHDI pseudo device.

I tried doing a fresh install of Vicibox 8.1.2 withOUT doing the “#zypper up –y” step by doing the commands:

#yast lan
Setup my static ip address, gateway, eth0
I skipped the #zypper up -y step
#os-install
#vicidial-express

I setup the Carrier, Servers, User Group, User, Campaign

I use X-Lite softphone to login.

I am still having the same errors.
sue136
 
Posts: 5
Joined: Mon Nov 05, 2018 9:07 pm

Re: Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo d

Postby sue136 » Wed Nov 07, 2018 5:47 pm

I tried running some test commands

asterisk -r
[Nov 5 18:42:47] Asterisk 13.21.1-vici, Copyright (C) 1999 - 2014, Digium, Inc. and others.
=========================================================================
[Nov 5 18:42:47] Connected to Asterisk 13.21.1-vici currently running on vicibox81 (pid = 667)
vicibox81*CLI> dahdi show status
No DAHDI found. Unable to open /dev/dahdi/ctl: No such file or directory
Command 'dahdi show status' failed.
[Nov 5 18:43:01] == Manager 'sendcron' logged on from 127.0.0.1

vicibox81*CLI> dahdi show version
Failed to open control file to get version.


vicibox81:~ # lsmod | grep dahdi
vicibox81:~ #


vicibox81:~ # service dahdi start
Job for dahdi.service failed because the control process exited with error code. See "systemctl status dahdi.service" and "journalctl -xe" for details.

vicibox81:~ # systemctl status dahdi.service
â dahdi.service - LSB: Load and initialize Dahdi.
Loaded: loaded (/etc/init.d/dahdi; bad; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2018-11-05 17:15:19 MST; 20s ago
Docs: man:systemd-sysv-generator(8)
Process: 14215 ExecStart=/etc/init.d/dahdi start (code=exited, status=1/FAILURE)

Nov 05 17:14:59 vicibox81 systemd[1]: Starting LSB: Load and initialize Dahdi....
Nov 05 17:14:59 vicibox81 dahdi[14215]: Loading DAHDI hardware modules:
Nov 05 17:14:59 vicibox81 dahdi[14215]: There aren't any DAHDI hardware modules specified to
Nov 05 17:14:59 vicibox81 dahdi[14215]: load. Please update /etc/dahdi/modules in order to
Nov 05 17:14:59 vicibox81 dahdi[14215]: specify the modules to load.
Nov 05 17:15:19 vicibox81 dahdi[14215]: Error: missing /dev/dahdi!
Nov 05 17:15:19 vicibox81 systemd[1]: dahdi.service: Control process exited, code=exited status=1
Nov 05 17:15:19 vicibox81 systemd[1]: Failed to start LSB: Load and initialize Dahdi..
Nov 05 17:15:19 vicibox81 systemd[1]: dahdi.service: Unit entered failed state.
Nov 05 17:15:19 vicibox81 systemd[1]: dahdi.service: Failed with result 'exit-code'.


vicibox81:~ # locate dahdi
/etc/dahdi
/etc/asterisk/chan_dahdi.conf
/etc/asterisk/dahdi-channels.conf
/etc/bash_completion.d/dahdi
/etc/dahdi/assigned-spans.conf
/etc/dahdi/assigned-spans.conf.sample
/etc/dahdi/genconf_parameters
/etc/dahdi/init.conf
/etc/dahdi/modules
/etc/dahdi/modules.sample
/etc/dahdi/span-types.conf.sample
/etc/dahdi/system.conf
/etc/dahdi/system.conf.bak
/etc/dahdi/system.conf.sample
/etc/init.d/dahdi
/etc/modprobe.d/dahdi-blacklist.conf
/lib/firmware/.dahdi-fw-a4a-a0017
/lib/firmware/.dahdi-fw-a4b-d001e
/lib/firmware/.dahdi-fw-a8a-1d0017
/lib/firmware/.dahdi-fw-a8b-1f001e
/lib/firmware/.dahdi-fw-hx8-2.06
/lib/firmware/.dahdi-fw-oct6114-032-1.05.01
/lib/firmware/.dahdi-fw-oct6114-064-1.05.01
/lib/firmware/.dahdi-fw-oct6114-128-1.05.01
/lib/firmware/.dahdi-fw-oct6114-256-1.05.01
/lib/firmware/.dahdi-fw-tc400m-MR6.12
/lib/firmware/.dahdi-fw-te133-7a001e
/lib/firmware/.dahdi-fw-te134-780017
/lib/firmware/.dahdi-fw-te435-13001e
/lib/firmware/.dahdi-fw-te436-10017
/lib/firmware/.dahdi-fw-te820-1.76
/lib/firmware/.dahdi-fw-vpmoct032-1.12.0
/lib/firmware/dahdi-fw-a4a.bin
/lib/firmware/dahdi-fw-a4b.bin
/lib/firmware/dahdi-fw-a8a.bin
/lib/firmware/dahdi-fw-a8b.bin
/lib/firmware/dahdi-fw-hx8.bin
/lib/firmware/dahdi-fw-oct6114-032.bin
/lib/firmware/dahdi-fw-oct6114-064.bin
/lib/firmware/dahdi-fw-oct6114-128.bin
/lib/firmware/dahdi-fw-oct6114-256.bin
/lib/firmware/dahdi-fw-tc400m.bin
/lib/firmware/dahdi-fw-te133.bin
/lib/firmware/dahdi-fw-te134.bin
/lib/firmware/dahdi-fw-te435.bin
/lib/firmware/dahdi-fw-te436.bin
/lib/firmware/dahdi-fw-te820.bin
/lib/firmware/dahdi-fw-vpmoct032.bin
/lib/modules/4.4.155-68-default/extra/dahdi.ko
/lib/modules/4.4.155-68-default/extra/dahdi_dynamic.ko
/lib/modules/4.4.155-68-default/extra/dahdi_dynamic_eth.ko
/lib/modules/4.4.155-68-default/extra/dahdi_dynamic_ethmf.ko
/lib/modules/4.4.155-68-default/extra/dahdi_dynamic_loc.ko
/lib/modules/4.4.155-68-default/extra/dahdi_echocan_jpah.ko
/lib/modules/4.4.155-68-default/extra/dahdi_echocan_kb1.ko
/lib/modules/4.4.155-68-default/extra/dahdi_echocan_mg2.ko
/lib/modules/4.4.155-68-default/extra/dahdi_echocan_oslec.ko
/lib/modules/4.4.155-68-default/extra/dahdi_echocan_sec.ko
/lib/modules/4.4.155-68-default/extra/dahdi_echocan_sec2.ko
/lib/modules/4.4.155-68-default/extra/dahdi_transcode.ko
/lib/modules/4.4.155-68-default/extra/dahdi_vpmadt032_loader.ko
/lib/modules/4.4.155-68-default/extra/voicebus/dahdi_voicebus.ko
/srv/www/htdocs/9JNGzri9x6NSI04F9x4nFsNTN4eGFewm/spy-dahdi.gsm
/usr/lib/perl5/vendor_perl/5.18.2/Dahdi/Config/Gen/Chandahdi.pm
/usr/lib/udev/rules.d/dahdi.rules
/usr/lib64/asterisk/modules/app_dahdiras.so
/usr/lib64/asterisk/modules/chan_dahdi.so
/usr/lib64/asterisk/modules/codec_dahdi.so
/usr/lib64/asterisk/modules/res_timing_dahdi.so
/usr/sbin/dahdi_cfg
/usr/sbin/dahdi_genconf
/usr/sbin/dahdi_hardware
/usr/sbin/dahdi_maint
/usr/sbin/dahdi_monitor
/usr/sbin/dahdi_registration
/usr/sbin/dahdi_scan
/usr/sbin/dahdi_span_assignments
/usr/sbin/dahdi_span_types
/usr/sbin/dahdi_speed
/usr/sbin/dahdi_test
/usr/sbin/dahdi_tool
/usr/sbin/dahdi_waitfor_span_assignments
/usr/sbin/lsdahdi
/usr/sbin/rcdahdi
/usr/share/dahdi
/usr/share/asterisk/configs/samples/chan_dahdi.conf.sample
/usr/share/asterisk/sounds/spy-dahdi.gsm
/usr/share/dahdi/FPGA_1141.hex
/usr/share/dahdi/FPGA_1151.hex
/usr/share/dahdi/FPGA_1161.201.hex
/usr/share/dahdi/FPGA_1161.202.hex
/usr/share/dahdi/FPGA_1161.203.hex
/usr/share/dahdi/FPGA_1161.hex
/usr/share/dahdi/FPGA_FXS.hex
/usr/share/dahdi/PIC_TYPE_1.hex
/usr/share/dahdi/PIC_TYPE_2.hex
/usr/share/dahdi/PIC_TYPE_3.hex
/usr/share/dahdi/PIC_TYPE_4.hex
/usr/share/dahdi/USB_FW.201.hex
/usr/share/dahdi/USB_FW.202.hex
/usr/share/dahdi/USB_FW.203.hex
/usr/share/dahdi/USB_FW.hex
/usr/share/dahdi/USB_RECOV.hex
/usr/share/dahdi/XppConfig.pm
/usr/share/dahdi/astribank_hook
/usr/share/dahdi/dahdi_auto_assign_compat
/usr/share/dahdi/dahdi_handle_device
/usr/share/dahdi/dahdi_span_config
/usr/share/dahdi/handle_device.d
/usr/share/dahdi/init_card_1_30
/usr/share/dahdi/init_card_2_30
/usr/share/dahdi/init_card_3_30
/usr/share/dahdi/init_card_4_30
/usr/share/dahdi/init_card_5_30
/usr/share/dahdi/span_config.d
/usr/share/dahdi/waitfor_xpds
/usr/share/dahdi/xpp_fxloader
/usr/share/dahdi/handle_device.d/10-span-types
/usr/share/dahdi/handle_device.d/20-span-assignments
/usr/share/dahdi/span_config.d/10-dahdi-cfg
/usr/share/dahdi/span_config.d/20-fxotune
/usr/share/dahdi/span_config.d/40-asterisk
/usr/share/dahdi/span_config.d/50-asterisk
/var/adm/fillup-templates/sysconfig.dahdi


When I put in a command to reboot the computer I got a line saying:

dahdi telephony interface unloaded

Then after a bit it rebooted. Not sure if that is relevant or not.
sue136
 
Posts: 5
Joined: Mon Nov 05, 2018 9:07 pm

Re: Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo d

Postby Kumba » Thu Nov 08, 2018 8:49 am

You should be using the /etc/init.d/vicidial script to load the DAHDI drivers and Asterisk. I.E. /etc/init.d/vicidial start or /etc/init.d/vicidial stop

If you've enabled the DAHDI or Asterisk init scripts then that is likely the source of your problem.
Kumba
 
Posts: 750
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo d

Postby sue136 » Thu Nov 08, 2018 12:59 pm

Thank you @Kumba for the reply.

I believe I have now fixed the problem. I am posting more details to assist others that may have the same problem and may need additional assistance.

I rebooted the computer and I ran commands to see the status

vicibox81:~ # /etc/init.d/vicidial status
Checking status for ViciDial Telephony Server... Asterisk has been up for /usr/sbin/asterisk -rx core show uptime | /usr/bin/grep System
Asterisk running on PID 646
Asterisk Screen running on PID
Astshell Screen running on PID
rc_status: Usage: [-v[<num>] [-r]|-s|-u]
â vicidial.service - LSB: ViciDial Telephony Server
Loaded: loaded (/etc/init.d/vicidial; bad; vendor preset: disabled)
Active: active (exited) since Thu 2018-11-08 08:25:48 MST; 1h 2min ago
Docs: man:systemd-sysv-generator(8)
Process: 1234 ExecStart=/etc/init.d/vicidial start (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 512)
vicibox81:~ # /etc/init.d/asterisk status
Checking for asterisk running
â asterisk.service - Asterisk PBX
Loaded: loaded (/usr/lib/systemd/system/asterisk.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2018-11-08 08:25:06 MST; 1h 4min ago
Main PID: 646 (asterisk)
Tasks: 103 (limit: 512)
CGroup: /system.slice/asterisk.service
ââ646 /usr/sbin/asterisk -fn
vicibox81:~ # /etc/init.d/dahdi status
Checking for dahdi ... no modules loaded. unused
â dahdi.service - LSB: Load and initialize Dahdi.
Loaded: loaded (/etc/init.d/dahdi; bad; vendor preset: disabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)


Then I ran the "yast" command and went into system - services manager to see what services were running.

I had previously Enabled both asterisk and vicidial.

So I Disabled the asterisk service in the yast services manager and rebooted the server and now it is working properly. I can login to the Agent Login area using X-Lite and am now getting the proper message - "you are currently the only person in this conference" and I am able to successfully place an outbound call.

Now when I run the status commands, this is what I get:

vicibox81:~ # /etc/init.d/vicidial status
Checking status for ViciDial Telephony Server... Asterisk has been up for /usr/sbin/asterisk -rx core show uptime | /usr/bin/grep System
Asterisk running on PID 1528
Asterisk Screen running on PID 1522
Astshell Screen running on PID 1517
rc_status: Usage: [-v[<num>] [-r]|-s|-u]
â vicidial.service - LSB: ViciDial Telephony Server
Loaded: loaded (/etc/init.d/vicidial; bad; vendor preset: disabled)
Active: active (running) since Thu 2018-11-08 10:05:45 MST; 41min ago
Docs: man:systemd-sysv-generator(8)
Process: 1303 ExecStart=/etc/init.d/vicidial start (code=exited, status=0/SUCCESS)
Tasks: 116 (limit: 512)
CGroup: /system.slice/vicidial.service
ââ1517 /usr/bin/SCREEN -S astshell20181108100539
ââ1518 /bin/sh
ââ1522 SCREEN -L -S asterisk
ââ1523 /bin/sh
ââ1528 /usr/sbin/asterisk -vvvvvvvvvvvvvvvvvvvvvgcT
ââ1536 ip_relay 40569 127.0.0.1 4569 9999999
ââ1537 ip_relay 41569 127.0.0.1 4569 9999999
ââ1538 ip_relay 42569 127.0.0.1 4569 9999999
vicibox81:~ # /etc/init.d/asterisk status
Checking for asterisk running
â asterisk.service - Asterisk PBX
Loaded: loaded (/usr/lib/systemd/system/asterisk.service; disabled; vendor preset: disabled)
Active: inactive (dead)

vicibox81:~ # /etc/init.d/dahdi status
Checking for dahdi ... modules loaded. running
â dahdi.service - LSB: Load and initialize Dahdi.
Loaded: loaded (/etc/init.d/dahdi; bad; vendor preset: disabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)
sue136
 
Posts: 5
Joined: Mon Nov 05, 2018 9:07 pm

Re: Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo d

Postby sue136 » Thu Nov 08, 2018 1:00 pm

@kumba

A related question -- if I make changes to the asterisk files (either through modifying some of the settings using the Vicidial GUI interface or by editing the files directly such as sip.conf) and need to restart services, should I just be running the command "/etc/init.d/vicidial stop" and "/etc/init.d/vidicial start" and NOT run "/etc/init.d/asterisk restart"?
sue136
 
Posts: 5
Joined: Mon Nov 05, 2018 9:07 pm

Re: Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo d

Postby thephaseusa » Thu Nov 08, 2018 7:55 pm

systemctl status dahdi

Tells you if dahdi started correctly

(I have a box where i have to put in /etc/rc.d/after.local)
modprobe dahdi
systemctl start dahdi

To restart asterisk:
sytemctl restart asterisk
thephaseusa
 
Posts: 281
Joined: Tue May 16, 2017 2:23 pm

Re: Vicibox 8.1.2 Install –Agent Can't Login &DAHDI pseudo d

Postby Kumba » Sun Nov 11, 2018 8:20 pm

The vicidial init script should be starting DAHDI and Asterisk. You shouldn't need to use the other init scripts at all but strange things have happened.

If you make changes just reload them through the module for that change I.E. running 'sip reload'.
Kumba
 
Posts: 750
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 10 guests