install just goes to a blank screen

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

install just goes to a blank screen

Postby THUFIR » Wed Feb 04, 2015 8:24 pm

As far as I can tell the DVD of vicibox I burned checks out as fine:

http://unix.stackexchange.com/questions/182988/

The md5sum for the .iso confirms; the md5sum for the DVD checks out as fine; the DVD itself checks out as fine. Yet, when I go to install, after the boot splash screen, it goes completely blank -- just a black screen.

Is there some way to get more output during the install process?
ViciBox Redux v.6.0.3-141118 from .iso | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation | AMD Phenom(tm) II X6 1090T Processor | 8GiB RAM
THUFIR
 
Posts: 109
Joined: Fri May 02, 2014 10:46 pm

Re: install just goes to a blank screen

Postby DomeDan » Thu Feb 05, 2015 5:16 am

after the boot splash screen it loads the kernel, so I guess that fails,
what hardware did you test this on? did you test the dvd on some other hardware? maybe on a normal desktop?

there might be a failsafe mode to select in the splash screen or you might be able to edit arguments to the kernel in the slash screen (press e maybe) add vga=791 or something if you can edit it
Vicidial Partner. Region: Sweden/Norway.
Does Vicidial installation, configuration, customization, add-ons, CRM implementation, support, upgrading, network-related, pentesting etc. Remote and onsite assistance.
Email: domedan (at) gmail.com
DomeDan
 
Posts: 1226
Joined: Tue Jan 04, 2011 9:17 am
Location: Sweden

Re: install just goes to a blank screen

Postby Kumba » Fri Feb 06, 2015 2:36 pm

This isn't really a fault of the DVD or OpenSuSE as much as it is how the linux kernel enables the video card drivers. It's most notable on ATI video chips. If you are booting off the CD/DVD trying to do the install you will need to press F3 at the grub splash screen and select "Text Mode". This will tell the kernel not to switch to higher graphics resolutions but to use the standard ASCII/ANSI BIOS output. The real fix comes into play that the kernel doesn't switch video modes to a video card driver that fails to initialize the video card properly. This change in resolutions and the re-initialization of the video card chipset is what fails. Like I mentioned, it's mostly found on onboard ATI chipsets but has been known to happen on others as well.

The other thing to consider is your monitor simply might not support the output resolution the kernel switches to. The linux kernel has a nasty habit of using the highest full-color resolution the video card chipset supports. It does not do an extended check to see what native resolution the monitor is. The fix is the same, you simply use 'Text Mode' when installing from the DVD or a lower resolution like '640x480'.

Truth be told the boot process is faster and the console is more responsive when using Text Mode anyways so it's recommended to use that as default. ViciBox v.6.0 attempts to set this up in grub but it doesn't always stick on updates.
Kumba
 
Posts: 812
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: install just goes to a blank screen

Postby THUFIR » Mon Feb 09, 2015 10:41 pm

Thank you, I'll try text mode. That probably will fix it. If not, I'll try OpenSuSE just for comparison?



Code: Select all

thufir@doge:~$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port D)
00:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port H)
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx1 port A)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller (rev 40)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
00:15.1 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 1)
00:15.2 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 2)
00:15.3 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 3)
00:16.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R9 270X]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
02:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01)
03:00.0 IDE interface: Marvell Technology Group Ltd. 88SE9172 SATA III 6Gb/s RAID Controller (rev 11)
04:0e.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
06:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01)
08:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)
09:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
thufir@doge:~$






I think it's actually too "high end" it's from razerzone.com :)
ViciBox Redux v.6.0.3-141118 from .iso | Single Server | No Digium/Sangoma Hardware | No Extra Software After Installation | AMD Phenom(tm) II X6 1090T Processor | 8GiB RAM
THUFIR
 
Posts: 109
Joined: Fri May 02, 2014 10:46 pm

Re: install just goes to a blank screen

Postby starkdust » Fri May 10, 2019 2:02 am

I am having same issues looks like it's my graphics card acting up, can any help me out? I am using this graphics card https://harddiskdirect.com/5188-4292-hp-video-card.html
starkdust
 
Posts: 1
Joined: Mon May 06, 2019 6:37 am

Re: install just goes to a blank screen

Postby williamconley » Tue May 14, 2019 3:17 pm

put the disk in another computer and see if it works there. like a laptop (just don't start the install, of course).

you may just have a bad burn disk.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 18981
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 11 guests