How to Install and setup ViciDialNow(w/SIP Service Provider)

General and Support topics relating to ViciDialNow and GoAutoDial ISO installers

Moderators: Kumba, mflorell, williamconley, enjay, Staydog, gardo, Op3r, mcargile, s0lid

How to Install and setup ViciDialNow(w/SIP Service Provider)

Postby pquiring » Tue Mar 24, 2009 6:27 pm

Ok, it took me a few days to get this setup so I thought I would explain what I did to get it to work.

1) Download and install vicidialnow.
The root password is 'vicidialnow'. If you need to change the IP address edit /etc/sysconfig/network_scripts/ifcfg-eth0 and change it then run 'update_server_ip' to update vicidial's config. I also had a problem with the OS using the router so I had to add 'route add -net 0.0.0.0 gw 192.168.1.1' to my /etc/rc.local file before Asterisk starts.

2) Configuring SIP Service provider
To do this you will have to use an SSH client (such as putty or cygwin/openssh) and use the linux 'vi' editor.
Connect as root and edit /etc/asterisk/sip.conf and add the following:

[trunk_1]
disallow=all
allow=ulaw
allow=alaw
type=friend
username=<username>
secret=<password>
host=<your_sip_provider>
dtmfmode=inband
qualify=1000
fromuser=<username>

The 'fromuser' is optional but is required when connecting to a SysMaster UniSwitch with a wholesale account.
Now we have to edit the extensions.conf file to tell asterisk to use our new trunk. The vicidial default config is setup to use a Zap interface.
Use vi and edit /etc/asterisk/extensions.conf
Look for SIPtrunk in the [globals] section and change it to:

SIPtrunk=SIP/trunk_1

Look for the line 'dial a long distance outbound number' and we will modify the 9 lines below it. (ignoring comment lines)
First comment the 3 lines directly below it. These are used to send outbound calls to TRUNKX (Zap/g2).
Skip over the next 3 lines and then uncomment the final 3 lines ('dial a long distance outbound number through a SIP provider').
And change them to this:

exten => _91NXXNXXXXXX,1,AGI(agi://127.0.0.1:4577/call_log)
exten => _91NXXNXXXXXX,2,Dial(${SIPtrunk}/${EXTEN:1},55,o)
exten => _91NXXNXXXXXX,3,Hangup

I figured this out by looking at the config of a clean asterisk system. Would have never figured it our otherwise.
Vicidial's default config is messed up.

That should do it. Run 'asterisk -r' to connect to asterisk and run 'reload' for the config to take effect (or reboot).

It worked for me.

Quick overview of how the system works:

Admin usage:

1) Logon as 'Administrator' and create your campaings, agents, lists and such.
2) Add #s to dial in the list in the format vicidial expects.

Agent usage:

1) Connect your VoIP phone to vicidial (ie: '101', 'test')
2) Logon to 'Agent' with phone details ('101', 'test') then your agent details (I just use admin for test) and select campaign.
When you login vicidial will 'call' your voip phone, pick it up and never hang up until you logoff for the day.
3) Click 'Dial next number' in the queue and your VoIP phone will automatically be connected (I think it uses some sort of conference method to do this). Click on 'hangup' and the webpage will ask you how to flag the number (Busy, etc.). Don't hangup your VoIP phone.
Repeat until your done for the day then logoff and hangup your VoIP phone.

Notes:
Make sure you put your campaign into 24hr mode while testing.
Try reseting your lists and campaigns while testing until you see something in your hopper. It takes a while but slowly works.

Enjoy!
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

Postby mflorell » Tue Mar 24, 2009 6:47 pm

Thank you very much for posting this!

If I get confirmation of these instructions from one of the VICIDIALnow guys then I will change it to a sticky so it stays at the top of this forum.
mflorell
Site Admin
 
Posts: 13965
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

More info

Postby pquiring » Fri Apr 03, 2009 2:22 pm

If you SIP provider is using IP authentication then your SIP file will be much simpler:

[trunk_1]
disallow=all
allow=ulaw
allow=alaw
type=friend
host=<your_sip_provider>
dtmfmode=inband
qualify=1000

And for international calls you need to comment out all lines for international calls (ie: exten => _9011...) and add the following to your extensions.conf:

exten => _9011NXXNXXXXXX,1,AGI(agi://127.0.0.1:4577/call_log)
exten => _9011NXXNXXXXXX,2,Dial(${SIPtrunk}/${EXTEN:1})
exten => _9011NXXNXXXXXX,3,Hangup

Enjoy!
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

Postby gardo » Fri Apr 03, 2009 2:43 pm

Sticky!!! :D
http://goautodial.com
Empowering the next generation contact centers
gardo
 
Posts: 1914
Joined: Fri Sep 15, 2006 10:24 am
Location: Manila, 1004

Re: How to Install and setup ViciDialNow(w/SIP Service Provi

Postby rozan1 » Mon May 04, 2009 5:09 am

[quote="pquiring"]

[trunk_1]
disallow=all
allow=ulaw
allow=alaw
type=friend
username=<username>
secret=<password>
host=<your_sip_provider>
dtmfmode=inband
qualify=1000
fromuser=<username>

If i understand correctly the above entry creates a context in sip.conf for all configured SIP users? My SIP.conf has config entries for each of the 30 users (i.e. cc100 - cc130) and each of them has different usernames, host and secret. In that case what would be the entries for these fields in the above [trunk_1] context?

Thanks for such a nice post.
rozan1
 
Posts: 12
Joined: Sun Apr 19, 2009 5:11 am
Location: Bangladesh

Postby ykhan » Tue Jun 16, 2009 1:23 pm

The trunk information is from your SIP provider and will not affect the phones you have configured for agents. THe Trunk info allows your Asterisk box to communicate with the provider for call termination outsite of your network. The cc100-cc130 are your phones and used for connecting your agents to yuor Asterisk box. Calls are bridged between your connected agents and your SIP provider.
Yousaf Khan
For installation and Support.
VoIP to North America from $0.009/min
Phone: +1 (647) 891-5426
Email: ykhan@duologuecommunications.com
ykhan
 
Posts: 352
Joined: Thu Jun 08, 2006 4:47 pm

Postby joylovebasu » Tue Jun 16, 2009 2:35 pm

Anyway to configure each agent with each different sip provider account ?

I want to do that as I want as I have a reseller panel and I have create 10 VOIP account and assign each of them to each agent, so that at the end of the months it become easy for me for finance.
joylovebasu
 
Posts: 127
Joined: Tue Jun 09, 2009 11:13 am

SIP config here and in getting started Guide

Postby vicidial0 » Tue Aug 18, 2009 10:22 am

hello

Do I have to do the config mentioned in Getting STarted guide including this one ?

the probelm is my vicidial is not autodialing any customer.

I am trying to dial customers in canada.

I just Did config mentioned in getting started guide..

didnt tried this
vicidial0
 
Posts: 3
Joined: Mon Aug 17, 2009 1:14 am

Internet Explorer patch

Postby pquiring » Wed Sep 16, 2009 1:17 pm

I've found the login page doesn't work with IE. It fails to populate the allowable campaigns. Do this to fix the problem:

vi /var/www/html/agc/vicidial.php

Look for
"function login_allowable_campaigns()"
and change it to
"function login_allowable_campaigns_disable()"

It's a hack but it works for me!

We've been using ViciDial the past week and it works great!
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

Postby mflorell » Wed Sep 16, 2009 4:50 pm

What version of IE?

What version and build of vicidial.php?
mflorell
Site Admin
 
Posts: 13965
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Networking fix

Postby pquiring » Thu Sep 17, 2009 8:19 pm

Ok, in my org post I said that I had to add a route command to the rc.local file. I figured out why. The ifcfg-eth0 file in /etc/sysconfig/network-scripts is missing the GATEWAY line.
So add:
GATEWAY=192.168.1.1
or whatever your gateway is instead of editing your rc.local file.
Also make sure /etc/resolv.conf has a valid nameserver line.

TTYL
Last edited by pquiring on Thu Sep 17, 2009 8:26 pm, edited 1 time in total.
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

Postby pquiring » Thu Sep 17, 2009 8:25 pm

mflorell wrote:What version of IE?

What version and build of vicidial.php?


IE8 but I think other versions are the same (6,7). We are using ViciDialNow 1.2. The last entry in the files CHANGELOG is 81012-0857.

What happens is when you login the javascript function empties the campaign list so you can't login.
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

NAT firewall

Postby pquiring » Sat Sep 19, 2009 7:13 am

Here is some info if your vicidial box is behind a NATing firewall.

Edit /etc/asterisk/sip.conf:
In the [general] section add:
externip=x.x.x.x (your real internet address)
localnet=192.168.1.0/255.255.255.0

In the [truck1] section add:
nat=yes

And then it will work better.
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

RATIO/ADAPT Mode requires another change

Postby pquiring » Tue Sep 22, 2009 1:16 pm

I figured out something else today, there is another change that MUST be made in /etc/asterisk/extensions.conf if you are using SIP. Otherwise RATIO/ADAPT modes will not work.

Look for:
;#### VDAD STANDARD TRANSFER ENTRIES ####
and comment out the 7 blocks under it.

Then look for:
;#### VDAD SIP UNREGISTERED TRANSFER ENTRIES ####
and uncomment the 7 blocks under it.

Then RATIO/ADAPT modes will transfer calls to agents properly.

Enjoy!
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

makewhatis

Postby pquiring » Tue Sep 22, 2009 1:21 pm

There is a cron job that runs daily and weekly that has a heavy CPU load which is not needed.

delete (or comment out)
/etc/cron.daily/makewhatis.cron
and
/etc/cron.weekly/makewhatis.cron

makewhatis just reindexes man pages (you shouldn't be installing new man pages on a production system).

Enjoy!
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

VDAD SIP entries

Postby pquiring » Wed Sep 23, 2009 4:03 pm

If you can't find the VDAD SIP transfer entries here they are (add to /etc/asterisk/extensions.conf). Maybe some versions don't have it. I'm using VDNow/1.2 CE. Remember to comment out the standard entries.

;#### VDAD SIP UNREGISTERED TRANSFER ENTRIES ####
;#### Use these entries IN PLACE OF the entries above if you are using SIP trunks
;#### and are not registering your provider in sip.conf
;; VICIDIAL_auto_dialer transfer script for no-agent campaigns:
exten => 8364,1,Playback(sip-silence)
exten => 8364,2,AGI(agi://127.0.0.1:4577/call_log)
exten => 8364,3,AGI(agi-VDADtransferBROADCAST.agi,${EXTEN})
exten => 8364,4,AGI(agi-VDADtransferBROADCAST.agi,${EXTEN})
exten => 8364,5,Hangup
;
;; VICIDIAL_auto_dialer transfer script:
exten => 8365,1,Playback(sip-silence)
exten => 8365,2,AGI(agi://127.0.0.1:4577/call_log)
exten => 8365,3,AGI(agi-VDADtransfer.agi,${EXTEN})
exten => 8365,4,AGI(agi-VDADtransfer.agi,${EXTEN})
exten => 8365,5,Hangup
;
;; VICIDIAL_auto_dialer transfer script SURVEY at beginning:
exten => 8366,1,Playback(sip-silence)
exten => 8366,2,AGI(agi://127.0.0.1:4577/call_log)
exten => 8366,3,AGI(agi-VDADtransferSURVEY.agi,${EXTEN})
exten => 8366,4,AGI(agi-VDADtransferSURVEY.agi,${EXTEN})
exten => 8366,5,Hangup
;
;; VICIDIAL_auto_dialer transfer script Load Balance Overflow:
exten => 8367,1,Playback(sip-silence)
exten => 8367,2,AGI(agi://127.0.0.1:4577/call_log)
exten => 8367,3,AGI(agi-VDAD_LO_transfer.agi,${EXTEN})
exten => 8367,4,AGI(agi-VDAD_LO_transfer.agi,${EXTEN})
exten => 8367,5,Hangup
;
;; VICIDIAL_auto_dialer transfer script Load Balanced:
exten => 8368,1,Playback(sip-silence)
exten => 8368,2,AGI(agi://127.0.0.1:4577/call_log)
exten => 8368,3,AGI(agi-VDAD_LB_transfer.agi,${EXTEN})
exten => 8368,4,AGI(agi-VDAD_LB_transfer.agi,${EXTEN})
exten => 8368,5,Hangup
;
;; VICIDIAL_auto_dialer transfer script AMD with Load Balanced:
exten => 8369,1,Playback(sip-silence)
exten => 8369,2,AGI(agi://127.0.0.1:4577/call_log)
exten => 8369,3,AMD(2000|2000|1000|5000|120|50|4|256)
exten => 8369,4,AGI(VD_amd.agi,${EXTEN})
exten => 8369,5,AGI(agi-VDAD_LB_transfer.agi,${EXTEN})
exten => 8369,6,AGI(agi-VDAD_LB_transfer.agi,${EXTEN})
exten => 8369,7,Hangup
;
;; VICIDIAL auto-dial reminder script
exten => 8372,1,Playback(sip-silence)
exten => 8372,2,AGI(agi://127.0.0.1:4577/call_log)
exten => 8372,3,AGI(agi-VDADautoREMINDER.agi,${EXTEN})
exten => 8372,4,AGI(agi-VDADautoREMINDER.agi,${EXTEN})
exten => 8372,5,Hangup
pquiring
 
Posts: 10
Joined: Tue Mar 24, 2009 6:02 pm

Vicidial Agent Login Screen - Campaign not showing up

Postby aamiriqbal » Wed Sep 23, 2009 4:52 pm

Hi pquiring,

Thanks for all your help.

I followed the step by step instructions lay down by you and change the sip.conf and extensions.conf accordingly also I have added the ;#### VDAD SIP UNREGISTERED TRANSFER ENTRIES #### entries as you suggested.

I can manuall dial and everything seems working perfectly.

But, when I go and login into the Vicidial Agent Login Screen and upon entering the phone and user login I cannot see the Campaign there :( the campaign field is blanck. The test campaign is active and there are leads in the hopper.

Kindly advise.
aamiriqbal
 
Posts: 26
Joined: Wed Nov 19, 2008 1:27 pm
Location: Islamabad, Pakistan

Postby aamiriqbal » Wed Sep 23, 2009 4:54 pm

Hi pquiring,

Kindly note that I have changed the default IP to 192.168.1.4. I also edit /etc/sysconfig/network_scripts/ifcfg-eth0 and change it then run 'update_server_ip' to update vicidial's config.
aamiriqbal
 
Posts: 26
Joined: Wed Nov 19, 2008 1:27 pm
Location: Islamabad, Pakistan

Started working now

Postby aamiriqbal » Thu Sep 24, 2009 9:22 am

Hi pquiring,

Alright, I can see the Campaing now, actually according to your post I made changes to vi /var/www/html/agc/vicidial.php

Changed:
"function login_allowable_campaigns()"
to:
"function login_allowable_campaigns_disable()"

I revert this change.

Thanks
aamiriqbal
 
Posts: 26
Joined: Wed Nov 19, 2008 1:27 pm
Location: Islamabad, Pakistan

Auto Dialing not working

Postby aamiriqbal » Thu Sep 24, 2009 10:08 am

Hi pquiring,

I can dial manually through asterisk and vicidial but with Auto (Ratio) I do not get any call, here is the CLI:

== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
> Channel SIP/cc100-08fa0750 was answered.
-- Executing MeetMe("SIP/cc100-08fa0750", "8600051|F") in new stack
== Parsing '/etc/asterisk/meetme.conf': Found
-- Created MeetMe conference 1023 for conference '8600051'
-- Playing 'conf-onlyperson' (language 'en')
== Manager 'sendcron' logged off from 127.0.0.1
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
-- Executing AGI("Local/918505161570@default-ece5,2", "agi://127.0.0.1:4577/call_log") in new stack
-- AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing Dial("Local/918505161570@default-ece5,2", "SIP/trunk_1/18505161570|55|o") in new stack
-- Called trunk_1/18505161570
-- SIP/trunk_1-08fbea98 is ringing
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1
== Refreshing DNS lookups.
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1
-- SIP/trunk_1-08fbea98 answered Local/918505161570@default-ece5,2
> Channel Local/918505161570@default-ece5,1 was answered.
== Manager 'sendcron' logged off from 127.0.0.1
-- Executing Playback("Local/918505161570@default-ece5,1", "sip-silence") in new stack
-- Playing 'sip-silence' (language 'en')
-- Executing AGI("Local/918505161570@default-ece5,1", "agi://127.0.0.1:4577/call_log") in new stack
-- AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing AGI("Local/918505161570@default-ece5,1", "agi-VDAD_LB_transfer.agi|8368") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/agi-VDAD_LB_transfer.agi
-- AGI Script agi-VDAD_LB_transfer.agi completed, returning 0
-- Executing AGI("Local/918505161570@default-ece5,1", "agi-VDAD_LB_transfer.agi|8368") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/agi-VDAD_LB_transfer.agi
-- AGI Script agi-VDAD_LB_transfer.agi completed, returning 0
-- Executing Hangup("Local/918505161570@default-ece5,1", "") in new stack
== Spawn extension (default, 8368, 5) exited non-zero on 'Local/918505161570@default-ece5,1'
-- Executing DeadAGI("Local/918505161570@default-ece5,1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16---------------") in new stack
-- AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ---------- completed, returning 0
== Spawn extension (default, 918505161570, 2) exited non-zero on 'Local/918505161570@default-ece5,2'
-- Executing DeadAGI("Local/918505161570@default-ece5,2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----39-----0") in new stack
-- AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... --39-----0 completed, returning 0
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1

extensions.conf:
; dial a long distance outbound number through a SIP provider
exten => _91NXXNXXXXXX,1,AGI(agi://127.0.0.1:4577/call_log)
exten => _91NXXNXXXXXX,2,Dial(${SIPtrunk}/${EXTEN:1},55,o)
exten => _91NXXNXXXXXX,3,Hangup

VicidialNow: CE 1.2 Final
Vicidial VERSION: 2.0.5-173
BUILD: 90320-0424

Any suggestions please?
aamiriqbal
 
Posts: 26
Joined: Wed Nov 19, 2008 1:27 pm
Location: Islamabad, Pakistan

Postby gardo » Thu Sep 24, 2009 11:06 am

Is your VicidialNOW server under a firewall/router? Has it been (firewall) configured properly?
http://goautodial.com
Empowering the next generation contact centers
gardo
 
Posts: 1914
Joined: Fri Sep 15, 2006 10:24 am
Location: Manila, 1004

Auto Dialing not working

Postby aamiriqbal » Thu Sep 24, 2009 11:21 am

No firewall is in place.

I have 2 servers the 2nd one is working properly.
aamiriqbal
 
Posts: 26
Joined: Wed Nov 19, 2008 1:27 pm
Location: Islamabad, Pakistan

Postby ramaseshi » Wed Nov 04, 2009 3:40 am

HI
I am also facing same problem. Not getting calls to agents in Vicidial NOw 1.2 CE. I followed all above steps.
ramaseshi
 
Posts: 25
Joined: Tue Sep 16, 2008 5:37 am

Postby mtmemon » Sun Nov 08, 2009 8:47 am

I am facing the same problem where I can see the calls ringing but are not passing on to the agent. Was any one able to get this matter resolved? I am using vicidialnow 1.2 CE the latest version, below is the cli:

-- AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing AGI("SIP/SIPtrunk1-08e916f0", "agi-VDAD_ALL_outbound.agi|NORMAL-----SO") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/agi-VDAD_ALL_outbound.agi
AGI Tx >> agi_request: agi-VDAD_ALL_outbound.agi
AGI Tx >> agi_channel: SIP/SIPtrunk1-08e916f0
AGI Tx >> agi_language: en
AGI Tx >> agi_type: SIP
AGI Tx >> agi_uniqueid: 1257704993.128
AGI Tx >> agi_callerid: 912143771345
AGI Tx >> agi_calleridname: unknown
AGI Tx >> agi_callingpres: 0
AGI Tx >> agi_callingani2: 0
AGI Tx >> agi_callington: 0
AGI Tx >> agi_callingtns: 0
AGI Tx >> agi_dnid: unknown
AGI Tx >> agi_rdnis: unknown
AGI Tx >> agi_context: default
AGI Tx >> agi_extension: 8365
AGI Tx >> agi_priority: 3
AGI Tx >> agi_enhanced: 0.0
AGI Tx >> agi_accountcode:
AGI Tx >>
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
== Manager 'sendcron' logged off from 127.0.0.1
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
== Manager 'sendcron' logged off from 127.0.0.1
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << CHANNEL STATUS SIP/SIPtrunk1-08e916f0
AGI Tx >> 200 result=6
AGI Rx << HANGUP
AGI Tx >> 200 result=1
== Spawn extension (default, 8365, 3) exited non-zero on 'SIP/SIPtrunk1-08e916f0'
-- Executing DeadAGI("SIP/SIPtrunk1-08e916f0", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------") in new stack
AGI Tx >> agi_network_script: call_log--HVcauses--PRI-----NODEBUG-----0---------------
AGI Tx >> agi_request: agi://127.0.0.1:4577/call_log--HVcauses ... ----------
AGI Tx >> agi_channel: SIP/SIPtrunk1-08e916f0
AGI Tx >> agi_language: en
AGI Tx >> agi_type: SIP
AGI Tx >> agi_uniqueid: 1257704993.128
AGI Tx >> agi_callerid: 912143771345
AGI Tx >> agi_calleridname: unknown
AGI Tx >> agi_callingpres: 0
AGI Tx >> agi_callingani2: 0
AGI Tx >> agi_callington: 0
AGI Tx >> agi_callingtns: 0
AGI Tx >> agi_dnid: unknown
AGI Tx >> agi_rdnis: unknown
AGI Tx >> agi_context: default
AGI Tx >> agi_extension: h
AGI Tx >> agi_priority: 1
AGI Tx >> agi_enhanced: 0.0
AGI Tx >> agi_accountcode:
AGI Tx >>
-- AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ---------- completed, returning 0
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Parsing '/etc/asterisk/manager.conf': Found
== Manager 'sendcron' logged on from 127.0.0.1
== Manager 'sendcron' logged off from 127.0.0.1
mtmemon
 
Posts: 2
Joined: Fri Oct 30, 2009 10:13 am

How to configure Trunk with only IP

Postby kddacraker » Tue Nov 24, 2009 11:43 am

Hello there,

I understood to configure the sip account.

But how to configure the trunk with VOIP provider IP only.

Please guide

Thanks

_____________________________________________________

vicidialnow 1.2 CE
Dual core 2.8
2 GB Ram
Kunal Deshmukh
Prerana Technologies
| Email: kunal@preranatechnologies.com ; kddacraker@gmail.com | skype: kddacraker |
| MSN: preranatechnologies@live.in | Mobile: +91 985 000 5522 |
***Open Source Rocks***
kddacraker
 
Posts: 71
Joined: Fri Feb 15, 2008 5:18 am
Location: Nasik India

please help with dialplan and sip setup

Postby starfederal » Sat Dec 19, 2009 3:34 pm

Hi everybody, I am blind and need help with dialplans in vicidialnow. Can somebody help?
Dont think I have it set up properly.
Cant use ssh well either.
I will send you the ip to login if possible.
Thank you. :?
starfederal
 
Posts: 32
Joined: Sat Dec 19, 2009 2:52 pm
Location: Earth

Postby ronaldmedina74 » Thu Jan 14, 2010 9:33 pm

I figured out something else today, there is another change that MUST be made in /etc/asterisk/extensions.conf if you are using SIP. Otherwise RATIO/ADAPT modes will not work.

Look for:
;#### VDAD STANDARD TRANSFER ENTRIES ####
and comment out the 7 blocks under it.

-----------------------------------
----- what particular block ?
-----------------------------------
Then look for:
;#### VDAD SIP UNREGISTERED TRANSFER ENTRIES ####
and uncomment the 7 blocks under it.

----------------------------------
----- what particular block ?
----------------------------------

Then RATIO/ADAPT modes will transfer calls to agents properly

==================

Do i have to change also the extension for vicidialnow 1.3 ?
ronaldmedina74
 
Posts: 11
Joined: Sat Aug 01, 2009 2:35 pm

Help with 2 Server Install

Postby ajienolasco » Thu Jan 28, 2010 10:28 am

I don't know if I am in the right post, but can anyone point me to instructions on how to install ViciDialNow using two servers (with a third one for recording storage and other backups on a NAS)?

I am helping a friend setup a call center with 50 agents, and we need to be up and running by the end of this week, so any help would be highly appreciated. Also, I am in Cebu City and anyone who would like to join me in the project would be highly welcomed. Online assistance will also be very helpful.
ajienolasco
 
Posts: 6
Joined: Thu Jan 28, 2010 5:17 am

Postby gardo » Thu Jan 28, 2010 11:09 am

Are you referring to a multi-server setup? The database/web server and Vicidial/Asterisk on two separate machines? You can check the load_balancing.txt on the Astguiclient zip file. It details how to do a load balancing/multi-server setup.
http://goautodial.com
Empowering the next generation contact centers
gardo
 
Posts: 1914
Joined: Fri Sep 15, 2006 10:24 am
Location: Manila, 1004

Postby ajienolasco » Fri Jan 29, 2010 9:50 pm

Yes, I am referring to multiserver setup. I have two servers now loaded with vicidialnow. I want to use one server for the asterisk and the other server for database/web servers but I can not find from the load_balancing.txt a detailed instruction on how to do it. Maybe it is there but I just could not figure out which. I am not an expert in this matter, a total newbie who has never been to a call center until only three days ago, when my friend asked me to help him setup his servers and load vicidial.

I have only a few hours left to get the server up and running. If you can point me to the right direction, I will forever be indebted to you.
ajienolasco
 
Posts: 6
Joined: Thu Jan 28, 2010 5:17 am

Postby mte2005 » Tue Feb 16, 2010 4:59 pm

please a can't finished the steap listing in the vicidialnow pdf,
i'm in the last step, "page16of17" , after dialing the lead,
i have a message tel me 'You are currently the only person in this conference'
i do not hung up but the agent interface dont hung up automaticly and the call still up.
i like that i have i probleme any where but i can't localize it, please help me do this.
mte2005
 
Posts: 38
Joined: Tue Feb 16, 2010 4:19 pm

Postby gardo » Wed Feb 17, 2010 2:09 am

Please don't double-post.
http://goautodial.com
Empowering the next generation contact centers
gardo
 
Posts: 1914
Joined: Fri Sep 15, 2006 10:24 am
Location: Manila, 1004

Manual Dialing Issue

Postby caicedo2040 » Thu Feb 25, 2010 2:14 pm

HI everyone

Excelent from the begining, it just work as mentioned. I intalled vicidialnow 1.3 and made general settings according to user guide and this post. Campaign in ratio mode works perfect!!!!

I have an issue with "Manual mode" dialing. When I use this type of dialing, when next call button is clicked, I receive the message of "Invalid extension".

This same message was recieved in the beginning with ratio mode as well, but after modifications related to this post, the issue was solved for this mode, but manual mode campaign is not working.

Is it needed other modification for version 1.3?

Thanks

Juan
caicedo2040
 
Posts: 18
Joined: Thu Feb 25, 2010 2:05 pm

RE: Manual Dialing Issue

Postby caicedo2040 » Fri Feb 26, 2010 9:16 am

Hi,

I forgot to remove the dial prefix on the new campaign :? , so it was not an issue at the end. Now all is fine.

I'm testing this system for the last week with ratio dialing method and it works excellent.

Thanks for the post and for the developers of this product.

Juan
caicedo2040
 
Posts: 18
Joined: Thu Feb 25, 2010 2:05 pm

Postby gardo » Fri Feb 26, 2010 10:58 pm

You're welcome. :D Glad to hear everything is working fine.
http://goautodial.com
Empowering the next generation contact centers
gardo
 
Posts: 1914
Joined: Fri Sep 15, 2006 10:24 am
Location: Manila, 1004

Can any one tell me how to use eyebeam soft with Vicidialnow

Postby A.S.M. Nazmul Haque sobuz » Fri Mar 19, 2010 5:00 am

Hi I am sobuz. I am trying to setup a call center with vicidialnow. Can any one help me how to use eyebeam or x-lite softphone with ViciDialNow?
A.S.M. Nazmul Haque sobuz
 
Posts: 8
Joined: Fri Mar 19, 2010 4:39 am

Postby gmcust3 » Fri Mar 19, 2010 5:13 am

Download Managers Paid/Free Manual and Read and Go ahead from there.

Or

Contact some consultant who can do all for you..
GoAutoDial CE
VERSION: 2.4-309a
BUILD: 110430-1642
No other software installed on the box.
I've read the manager manual.
gmcust3
 
Posts: 1148
Joined: Sat Oct 24, 2009 1:15 pm

Re: Can any one tell me how to use eyebeam soft with Vicidia

Postby gardo » Fri Mar 19, 2010 11:30 am

Please don't double post.

A.S.M. Nazmul Haque sobuz wrote:Hi I am sobuz. I am trying to setup a call center with vicidialnow. Can any one help me how to use eyebeam or x-lite softphone with ViciDialNow?
http://goautodial.com
Empowering the next generation contact centers
gardo
 
Posts: 1914
Joined: Fri Sep 15, 2006 10:24 am
Location: Manila, 1004

Re: Internet Explorer patch

Postby callingcard » Wed Apr 28, 2010 10:01 am

Got the same problem and looked in the vicidial.php thingie, both in agc and agc2 directories.

Could you be more specific on what to do? Please.



pquiring wrote:I've found the login page doesn't work with IE. It fails to populate the allowable campaigns. Do this to fix the problem:

vi /var/www/html/agc/vicidial.php

Look for
"function login_allowable_campaigns()"
and change it to
"function login_allowable_campaigns_disable()"

It's a hack but it works for me!

We've been using ViciDial the past week and it works great!
callingcard
 
Posts: 19
Joined: Tue Apr 27, 2010 1:38 am

Re: Manual Dialing Issue

Postby moryainfotech » Thu Apr 29, 2010 12:11 pm

hi ,
i am also facing the same issue with vicidial 1.2 ce can you guide me on this issue.
moryainfotech
 
Posts: 2
Joined: Thu Apr 29, 2010 12:05 pm

Next

Return to ViciDialNow - GoAutoDial

Who is online

Users browsing this forum: No registered users and 3 guests