Changed default port 80 but unable to access call recordings

Any and all non-support discussions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Changed default port 80 but unable to access call recordings

Postby PJ111288 » Fri Apr 03, 2020 7:16 am

Hi,

I have changed default port 80 to 7415 in /etc/httpd/conf/httpd.conf to enable more security to access my dialer by agents and everything seems working fine but when i try to listen or download recording so it is still old ip without web port 7415.

web link to access admin and agent.

http://192.168.1.11:7415/agc/vicidial.php#

Recording link

http://192.168.1.11/RECORDINGS/GSM/2020 ... 92-all.gsm

So where do i need change so that i can access recording like this http://192.168.1.11:7415/RECORDINGS/GSM ... 92-all.gsm

Thanks.
PJ111288
 
Posts: 64
Joined: Tue Nov 13, 2018 7:41 am

Re: Changed default port 80 but unable to access call record

Postby williamconley » Fri Apr 03, 2020 4:31 pm

Are you using the ftp transfer option of the audio recording cron jobs? If so, it hard-codes the link. There is, however, a script to update those links.

/usr/share/astguiclient/ADMIN_update_archive_url.pl
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: Vicidial Agent Only Beep - Beta
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19730
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Changed default port 80 but unable to access call record

Postby PJ111288 » Sat Apr 04, 2020 7:14 am

Are you using the ftp transfer option of the audio recording cron jobs?

No.

As i mentioned my last post I am trying to add extra security layer by changing the default http 80 port and it is not updating on Recording link so how can i do this?

so that i can access recording like this http://192.168.1.11:7415/RECORDINGS/GSM ... 92-all.gsm

Thanks : )
PJ111288
 
Posts: 64
Joined: Tue Nov 13, 2018 7:41 am

Re: Changed default port 80 but unable to access call record

Postby PJ111288 » Sun May 23, 2021 3:07 am

Anyone can help me on this?

:(
PJ111288
 
Posts: 64
Joined: Tue Nov 13, 2018 7:41 am

Re: Changed default port 80 but unable to access call record

Postby carpenox » Sun May 23, 2021 7:17 am

cheange your vicirecord.conf to follow a more vhost setup


Image

look at the vhost template in /etc/apache2/vhosts.d/
Leap 15.2 | Version: 2.14-822a | BUILD: 210715-1248| SVN Version: 3483 | DB Schema Version: 1639 | Asterisk 13.38.2-vici
www.CyburDial.net -:- 844-PC-SATA-2 -:- My Blog: http://vicidial.blog -:- Whatsapp: +19549477572 -:- Skype: live:carpenox_3
carpenox
 
Posts: 1483
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: Changed default port 80 but unable to access call record

Postby PJ111288 » Sun May 23, 2021 7:39 am

:) thanks, carpenox, I was sure you will be helping me out.....

Many thanks for this but i have also found a very simple way which is

Admin>Server>Recording Web Link>ALT_IP
Alternate Recording Server IP > 1.1.1.1:2020

Thanks
AS
PJ111288
 
Posts: 64
Joined: Tue Nov 13, 2018 7:41 am

Re: Changed default port 80 but unable to access call record

Postby carpenox » Sun May 23, 2021 7:41 am

nice solution, great post back, good shit bro
Leap 15.2 | Version: 2.14-822a | BUILD: 210715-1248| SVN Version: 3483 | DB Schema Version: 1639 | Asterisk 13.38.2-vici
www.CyburDial.net -:- 844-PC-SATA-2 -:- My Blog: http://vicidial.blog -:- Whatsapp: +19549477572 -:- Skype: live:carpenox_3
carpenox
 
Posts: 1483
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 24 guests