Extra Data being exported via variable in webform

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Extra Data being exported via variable in webform

Postby kjburto » Mon Aug 02, 2021 10:54 am

Hello All,

I have a couple servers I host for a couple clients. They are all set up almost identically and one server is sending a ton of extra data via the variable in the webform. Only one server is doing it and none others. It just started happening the other day.

Here is the variable weblink it is using.

VARhttps: //xxx.xxxxxxservices.com/PSOnlineDP/dialer/newSaleNoVerifierIDoutbound.asp?DialID=--A--lead_id--B--&Company=--A--vendor_lead_code--B--&fname=--A--first_name--B--&lname=--A--last_name--B--&voice=--A--phone_number--B--&voice2=--A--alt_phone--B--&address=--A--address1--B--&address2=--A--address2--B--&city=--A--city--B--&st=--A--state--B--&zip=--A--postal_code--B--&email=--A--email--B--&weburl=--A--comments--B--&poptonew=1&cardtype=--A--Owner--B--&dob=--A--date_of_birth--B--&aname=--A--fullname--B--&DealerID=41&agent_id=--A--user--B--

Here is what it is sending:

https: //xxx.xxxxxxservices.com/PSOnlineDP/dialer/newSaleNoVerifierIDoutbound.asp?DialID=1967028&Company=&fname=susan&lname=reed&voice=6812012077&voice2=&address=512%20Virginia%20Avenue&address2=&city=WELCH&st=WV&zip=24801&email=reedsusan717%40gmail.com&weburl=&poptonew=1&cardtype=--A--Owner--B--&dob=0000-00-00&aname=DERRICK+PULVERMACHER&DealerID=41&agent_id=9201&lead_id=1967028&vendor_id=&list_id=7000&gmt_offset_now=-4.00&phone_code=1&phone_number=6812012077&title=&first_name=susan&middle_initial=&last_name=reed&address1=512%20Virginia%20Avenue&address2=&address3=216.30.147.96&city=WELCH&state=WV&province=&postal_code=24801&country_code=&gender=U&date_of_birth=0000-00-00&alt_phone=&email=reedsusan717%40gmail.com&security_phrase=&comments=&user=9201&pass=9201&orig_pass=9201&campaign=100_ID&phone_login=6012&original_phone_login=6012&phone_pass=6012&fronter=VDAD&closer=9201&group=100_ID&channel_group=100_ID&SQLdate=2021-07-30+105106&epoch=1627660267&uniqueid=1627660255.6170&customer_zap_channel=SIP/voipessential-00000737&customer_server_ip=192.168.1.9&server_ip=192.168.1.9&SIPexten=6012&session_id=8600053&phone=6812012077&parked_by=1967028&dispo=&dialed_number=6812012077&dialed_label=MAIN&source_id=&rank=0&owner=&camp_script=&in_script=&script_width=694&script_height=621&fullname=DERRICK+PULVERMACHER&agent_email=&recording_filename=100_ID_210730104403_4142926592_9201&recording_id=465038&user_custom_one=&user_custom_two=&user_custom_three=&user_custom_four=&user_custom_five=&preset_number_a=&preset_number_b=&preset_number_c=&preset_number_d=&preset_number_e=&preset_dtmf_a=&preset_dtmf_b=&did_id=&did_extension=&did_pattern=&did_description=&closecallid=&xfercallid=&agent_log_id=2047351&entry_list_id=7000&call_id=V7301050550001967028&user_group=NG_Closers&list_name=STEELE&list_description=STEELE%20LIVE%20LEADS&entry_date=2021-07-30+101826&did_custom_one=&did_custom_two=&did_custom_three=&did_custom_four=&did_custom_five=&called_count=2&email_row_id=&inOUT=OUT&LOGINvarONE=&LOGINvarTWO=&LOGINvarTHREE=&LOGINvarFOUR=&LOGINvarFIVE=&web_vars=&session_name=

Any ideas would be greatly helpful!

Server specs and Vici Specs
DELL PowerEdge R610 2 x 2.67Ghz E5640 Quad Core
Vicidial: VERSION: 2.14-671a BUILD: 180430-1834
kjburto
 
Posts: 80
Joined: Tue Aug 23, 2016 2:07 pm

Re: Extra Data being exported via variable in webform

Postby mflorell » Mon Aug 02, 2021 11:33 am

I can't say that I've seen anything like that happen before, although if the information in your signature is correct, you are running code from over 3 years ago. Could you confirm the version and build of the vicidial.php on these servers?
mflorell
Site Admin
 
Posts: 17848
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Extra Data being exported via variable in webform

Postby kjburto » Mon Aug 02, 2021 1:46 pm

I have been running this server for about 2-3 years I believe.

Version: 2.14b0.5
SVN Version: 2975
DB Schema Version: 1543
DB Schema Update Date: 2018-05-04 19:10:47


Also we had just changed it from "get call launch script" to the "Get call launch webform". I made this same change on all my servers and no other issues on any of them. This one however is sending all that extra data causing some fields to be duplicated in the Application the data gets sent to. This duplication gives them an error which is slowing things down for them.

Also server has been rebooted multiple times and I had the client reboot all their machines and clear cache from their browsers just to be on the safe side.
kjburto
 
Posts: 80
Joined: Tue Aug 23, 2016 2:07 pm

Re: Extra Data being exported via variable in webform

Postby mflorell » Mon Aug 02, 2021 2:43 pm

I would strongly suggest upgrading your servers, that version is years old and has quite a few known bugs in it that have been fixed in the more recent svn/trunk revisions, some related to webform URLS.
mflorell
Site Admin
 
Posts: 17848
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Extra Data being exported via variable in webform

Postby kjburto » Tue Aug 03, 2021 8:10 am

How difficult is it to upgrade? Are there instructions on how to do it. I have been using Vicidial for quite a while but not very great with linux itself. I have never really tried doing an upgrade as I have heard there can be issues, however I could be mistaken.
kjburto
 
Posts: 80
Joined: Tue Aug 23, 2016 2:07 pm

Re: Extra Data being exported via variable in webform

Postby mflorell » Tue Aug 03, 2021 8:23 am

As for VICIdial itself, just take a look at the UPGRADE document on your server, it has the steps to go through to upgrade your system.

Yes, there can be issues depending on how your system was installed and how old your Linux/MySQL/PHP versions are, although we have upgraded much older client systems successfully, including one client earlier this year that was using a 8-year-old version.

What are your Linux version, MySQL(MariaDB) version and PHP version?
mflorell
Site Admin
 
Posts: 17848
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Extra Data being exported via variable in webform

Postby kjburto » Tue Aug 03, 2021 8:29 am

I'm not entirely sure I just installed everything from the vicibox install image. Is there a way to see this in the admin page or PHP?
kjburto
 
Posts: 80
Joined: Tue Aug 23, 2016 2:07 pm

Re: Extra Data being exported via variable in webform

Postby mflorell » Tue Aug 03, 2021 1:07 pm

Well, the first question is which version of VICIbox did you install?

As for PHP, just log into Linux and type "php -v"

For MySQL, just log into Linux and type "mysql -V"
mflorell
Site Admin
 
Posts: 17848
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida

Re: Extra Data being exported via variable in webform

Postby kjburto » Tue Aug 03, 2021 1:12 pm

Okay so I installed vicibox v.8.0.1 and PHP is version 5.5.14 and MySql is version 15.1 Distrib 10.2.14-Maria-DB

I am probably going to just have poundteam do it for me as I really don't want anything to get screwed up.
kjburto
 
Posts: 80
Joined: Tue Aug 23, 2016 2:07 pm

Re: Extra Data being exported via variable in webform

Postby carpenox » Tue Aug 03, 2021 1:52 pm

If you cant get them to do it fast enough for you i can help you as well.
Leap 15.3 | Version: 2.14-829a | BUILD: 210911-1958| SVN Version: 3520 | DB Schema Version: 1645 | Asterisk 16.20.0-vici
www.CyburDial.net -:- 844-PC-SATA-2 -:- My Blog: http://vicidial.blog -:- Whatsapp: +19549477572 -:- Skype: live:carpenox_3
carpenox
 
Posts: 1575
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: Extra Data being exported via variable in webform

Postby kjburto » Tue Aug 03, 2021 2:15 pm

carpenox wrote:If you cant get them to do it fast enough for you i can help you as well.


Thanks I sent you a PM
kjburto
 
Posts: 80
Joined: Tue Aug 23, 2016 2:07 pm

Re: Extra Data being exported via variable in webform

Postby mflorell » Tue Aug 03, 2021 8:21 pm

You should be able to upgrade VICIdial only without too many issues if those are the versions you are using.
mflorell
Site Admin
 
Posts: 17848
Joined: Wed Jun 07, 2006 2:45 pm
Location: Florida


Return to Support

Who is online

Users browsing this forum: No registered users and 72 guests