ViciBox 9.x support for openSUSE Leap 15.2

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

ViciBox 9.x support for openSUSE Leap 15.2

Postby roger.milligan » Fri Feb 12, 2021 9:27 am

Hello

Loving ViciBox - thanks for all that the team does on this.

We are busy building a new ViciBox cluster for a 400 agent call centre - 8 x Dell R440s

We are installing ViciBox (using http://download.vicidial.com/iso/vicibo ... 0.3-md.iso) and we see that openSUSE Leap 15.1 is end of life and openSUSE Leap 15.2 is the current version:
https://en.opensuse.org/Lifetime
The following distributions have reached their end of life and should not be used:
openSUSE Leap 15.1 - Feb 2nd 2021 - (done)
openSUSE Leap 15.0 - Dec 3rd 2019 - (done)
...

Are there any plans to include v 15.2? Or any advice about possibly upgrading to v15.2 after installing ViciBox? Any advice will be much appreciated.

We did try and do a ‘zypper ref' etc but that failed and then tried an online update using Yast, but it gave the error "These products have reached end of general support and thus do not provide new updates anymore..."

We would like to have all the latest versions installed before going live - if possible.

Thanks for the help.

Roger
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791412325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 43
Joined: Sun Jul 19, 2015 12:18 pm
Location: Cape Town, South Africa

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby carpenox » Fri Feb 12, 2021 9:41 am

Its already being brought in:

https://download.opensuse.org/repositor ... Leap_15.2/

And zypper ref shouldnt have failed on 15.1. I use it everyday.

Image
Leap 15.2 | Version: 2.14-815a | BUILD: 210615-1108 | SVN Version: 3456 | DB Schema Version: 1635 | Asterisk 16.17.0-vici
www.CyburityLLC.com -:- 844-PC-SATA-2 -:- My Blog: the.cyburhacker.com -:- Whatsapp: +19549477572 -:- Skype: live:carpenox_3
carpenox
 
Posts: 1362
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby Kumba » Thu Mar 18, 2021 9:24 am

At the moment, only the Python repository is broken in ViciBox v.9. This is really only an issue for the certbot stuff which is broken cause of certbot.

It's safe to continue despite the error. ViciBox v.10 is being worked on with OpenSuSE v.15.3 as the planned OS.
Kumba
 
Posts: 886
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby roger.milligan » Thu Mar 18, 2021 9:59 am

Thanks carpenox & Kumba

We're in final testing to go live and we ended up having to leave the 4 dialer servers on openSUSE Leap 15.1 and the web & DB are on 15.2 because we could not get the Amfeltec USB timers working.

http://download.opensuse.org/repositori ... .1/x86_64/ has these 2 RPMs:
- voicesync-1.3.8-lp151.1.114.x86_64.rpm
- voicesync-kmp-default-1.3.8_k4.12.14_lp151.28.91-lp151.1.114.x86_64.rpm

http://download.opensuse.org/repositori ... .2/x86_64/
- is missing both of these

Not sure if we missed something else due to our limited knowledge on how to re-build the VoiceSync kernel components, and I don't have the exact error messages from the make right now, but we gave up.

Roger
------------------------------------------------------------------------------------------------------
Roger Milligan
Thrive, Cape Town, South Africa.
Mobile: +27 791412325 rogerm(at)thrivedatasolutions(dot)com
roger.milligan
 
Posts: 43
Joined: Sun Jul 19, 2015 12:18 pm
Location: Cape Town, South Africa

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby Kumba » Thu Mar 18, 2021 10:17 am

The Voicesync drivers don't support the kernels in 15.2 or 15.3 yet. I've contacted Amfletec to update them but it will probably be a few weeks before they have something ready for me.
Kumba
 
Posts: 886
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby nabobs » Sat Mar 20, 2021 4:35 pm

Kumba wrote:The Voicesync drivers don't support the kernels in 15.2 or 15.3 yet. I've contacted Amfletec to update them but it will probably be a few weeks before they have something ready for me.


So essentially we can't update opensuse to 15.2 otherwise the voice function won't work?...
nabobs
 
Posts: 29
Joined: Wed Mar 10, 2021 4:59 pm

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby carpenox » Sun Mar 21, 2021 8:56 pm

the voice function works just fine, i have upgraded all my servers to 15.2 and the systems are fully functional
Leap 15.2 | Version: 2.14-815a | BUILD: 210615-1108 | SVN Version: 3456 | DB Schema Version: 1635 | Asterisk 16.17.0-vici
www.CyburityLLC.com -:- 844-PC-SATA-2 -:- My Blog: the.cyburhacker.com -:- Whatsapp: +19549477572 -:- Skype: live:carpenox_3
carpenox
 
Posts: 1362
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby Kumba » Wed Mar 31, 2021 3:31 am

The VoiceSync drivers aren't available. If you are using the Amfletec timer modules then those won't work when you upgrade to 15.2. You can still use the standard DAHDI 'dummy' timers just fine.
Kumba
 
Posts: 886
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby kashinc » Fri Apr 16, 2021 2:11 pm

Hey Kumba,

Any luck with the Amfletec Voicesync drivers yet?

-kashinc
kashinc
 
Posts: 61
Joined: Thu Apr 23, 2015 12:04 pm

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby Kumba » Wed Apr 21, 2021 1:57 pm

kashinc wrote:Hey Kumba,

Any luck with the Amfletec Voicesync drivers yet?

-kashinc


Waiting on Amfletec to write new drivers. I'm just hurrying up and waiting like the rest of you :)
Kumba
 
Posts: 886
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby carpenox » Wed Apr 21, 2021 3:11 pm

lol kumba

hurry up and wait!!
Leap 15.2 | Version: 2.14-815a | BUILD: 210615-1108 | SVN Version: 3456 | DB Schema Version: 1635 | Asterisk 16.17.0-vici
www.CyburityLLC.com -:- 844-PC-SATA-2 -:- My Blog: the.cyburhacker.com -:- Whatsapp: +19549477572 -:- Skype: live:carpenox_3
carpenox
 
Posts: 1362
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby Kumba » Thu Apr 22, 2021 1:33 pm

Amfletec released a new v.1.3.9 driver. I've put it up on the repo so feel free to download it and test it out.
Kumba
 
Posts: 886
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox 9.x support for openSUSE Leap 15.2

Postby carpenox » Thu Apr 22, 2021 4:40 pm

nice, thank you sir
Leap 15.2 | Version: 2.14-815a | BUILD: 210615-1108 | SVN Version: 3456 | DB Schema Version: 1635 | Asterisk 16.17.0-vici
www.CyburityLLC.com -:- 844-PC-SATA-2 -:- My Blog: the.cyburhacker.com -:- Whatsapp: +19549477572 -:- Skype: live:carpenox_3
carpenox
 
Posts: 1362
Joined: Wed Apr 08, 2020 2:02 am
Location: Coral Springs, FL


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 18 guests